geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-3529) move new client/server security classes to a different package
Date Mon, 28 Aug 2017 21:47:00 GMT

    [ https://issues.apache.org/jira/browse/GEODE-3529?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16144401#comment-16144401
] 

ASF subversion and git services commented on GEODE-3529:
--------------------------------------------------------

Commit ed3ac98cec1610bde2c1cbcad5a0ff542296ea2a in geode's branch refs/heads/feature/GEODE-3529
from [~bschuchardt]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=ed3ac98 ]

GEODE-3529 move new client/server security classes to a different package

The new classes/interfaces have been moved to org.apache.geode.security.server.

A package.html is now provided that describes the purpose of the package.

The word "Stream" has been removed from the names of these classes.  Those
names make sense in the context of the Protobuf support classes in
org.apache.geode.internal.cache.tier.sockets classes but not when taken
as a separate group of classes.

The method Authenticator.receiveMessage() has been renamed to
Authenticator.authenticate().


> move new client/server security classes to a different package
> --------------------------------------------------------------
>
>                 Key: GEODE-3529
>                 URL: https://issues.apache.org/jira/browse/GEODE-3529
>             Project: Geode
>          Issue Type: Task
>          Components: client/server
>            Reporter: Bruce Schuchardt
>             Fix For: 1.3.0
>
>
> The StreamAuthenticator, StreamAuthorizer and associated classes were put in the org.apache.geode.security
package but they are only peripherally associated with the other classes in that package.
 They should be moved to a different package that has its own package.html.
> The "Stream" name should be removed since they are intended for client/server authentication
and authorization and _not_ authentication of streams in general.  Also, the method "receiveMessage"
seems an odd name for requesting authentication.  Perhaps "authenticate" would be better?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message