geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (GEODE-3258) Refactor DiskStoreCommands
Date Mon, 07 Aug 2017 17:13:00 GMT


ASF GitHub Bot commented on GEODE-3258:

GitHub user YehEmily reopened a pull request:

    GEODE-3258: Refactoring DiskStoreCommands

    [View the JIRA ticket here.](
    `DiskStoreCommands` was a huge class that contained a large number of commands. These
commands have been split into their own individual command classes. Two methods shared by
several commands were moved into `DiskStoreCommandsUtils` (it has been mentioned before that
--Utils classes should be avoided, but because a better home for these methods could not be
found, this issue may be resolved later in the future).
    Some tests were also updated - `DiskStoreCommandsJUnitTest` and `ListAndDescribeDiskStoreCommandsDUnitTest`.
It really looks like the two tests share many of the same functionalities... I think that
`ListAndDescribeDiskStoreCommandsDUnitTest` could be removed, since `DiskStoreCommandsJUnitTest`
already seems to test `ListDiskStoreCommand` and `DescribeDiskStoreCommand`, and `DiskStoreCommandsJUnitTest`
should be updated to test more commands, since it only seems to be testing `list disk-store`
and `describe disk-store`.
    **TESTING STATUS: Precheckin in progress**
    - [x] JIRA ticket referened
    - [x] PR rebased
    - [x] Initial commit is single and squashed
    - [x] `gradlew build` runs cleanly
    - [x] Unit tests updated

You can merge this pull request into a Git repository by running:

    $ git pull GEODE-3258

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #687
commit 55bd2b1613ea02a895b8f38b9760d14c5ffa531e
Author: YehEmily <>
Date:   2017-08-03T16:00:08Z

    GEODE-3258: Refactoring DiskStoreCommands


> Refactor DiskStoreCommands
> --------------------------
>                 Key: GEODE-3258
>                 URL:
>             Project: Geode
>          Issue Type: Sub-task
>          Components: gfsh
>            Reporter: Emily Yeh
>            Assignee: Emily Yeh
> {{}} is a large class that contains multiple commands. Each command
should be refactored into a separate class, and the methods shared by the commands should
be refactored into a new and appropriately named class of their own.

This message was sent by Atlassian JIRA

View raw message