geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-2558) Upgrade mockito dependency
Date Wed, 14 Jun 2017 18:07:00 GMT

    [ https://issues.apache.org/jira/browse/GEODE-2558?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16049457#comment-16049457
] 

ASF subversion and git services commented on GEODE-2558:
--------------------------------------------------------

Commit b616e80d1f9583eead82917f95ba5d9da4eb4f05 in geode's branch refs/heads/develop from
[~jstewart]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=b616e80 ]

GEODE-2558: Upgrade Powermock version to fix failing tests


> Upgrade mockito dependency
> --------------------------
>
>                 Key: GEODE-2558
>                 URL: https://issues.apache.org/jira/browse/GEODE-2558
>             Project: Geode
>          Issue Type: Wish
>          Components: build, tests
>            Reporter: Kirk Lund
>            Assignee: Kirk Lund
>
> Mockito should be upgrade from 1.x to 2.x.
> 1.10.19 (Dec, 2014) <-- current version
> 2.7.11 (Feb 2017)
> This requires updating Powermock as well.
> Changes to dependency-versions.properties:
> {noformat}
> -mockito-core.version = 1.10.19
> +mockito-core.version = 2.7.11
> ...
> -powermock.version = 1.6.6
> +powermock.version = 1.7.0RC2
> {noformat}
> The upgrade from Mockito 1.x to 2.x includes breaking APIs. Even after updating the APIs
to compile, I still see a number of unit tests that use Mockito failing. These tests span
all of the components in Geode so it's a non-trivial upgrade.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message