geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-1983) Swagger is broken with integrated security
Date Tue, 18 Oct 2016 17:40:58 GMT

    [ https://issues.apache.org/jira/browse/GEODE-1983?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15586106#comment-15586106
] 

ASF GitHub Bot commented on GEODE-1983:
---------------------------------------

GitHub user kjduling opened a pull request:

    https://github.com/apache/incubator-geode/pull/263

    GEODE-1983: Swagger is broken with integrated security

    This required a simple configuration change.  The swagger endpoints needed to be marked
as permitAll so that the resources could be read.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/kjduling/incubator-geode feature/GEODE-1983

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/incubator-geode/pull/263.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #263
    
----
commit abf3ff1d41bb2bdb43dec0caa1cf4829d13921d3
Author: Kevin Duling <kduling@pivotal.io>
Date:   2016-10-18T17:33:37Z

    GEODE-1983: Swagger is broken with integrated security
    
    This required a simple configuration change.

----


> Swagger is broken with integrated security
> ------------------------------------------
>
>                 Key: GEODE-1983
>                 URL: https://issues.apache.org/jira/browse/GEODE-1983
>             Project: Geode
>          Issue Type: Bug
>          Components: rest (dev), security
>            Reporter: Diane Hardman
>            Assignee: Kevin Duling
>             Fix For: 1.1.0-incubating
>
>
> Swagger UI does not work with latest integrated security. After configuring security
manager and attempting up to open up Swagger UI we get a prompt for username and password.
Entering credentials does not bring up the UI, instead asking for credentials again.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message