geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-1570) developer REST API should be secured
Date Mon, 12 Sep 2016 19:31:21 GMT

    [ https://issues.apache.org/jira/browse/GEODE-1570?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15485056#comment-15485056
] 

ASF subversion and git services commented on GEODE-1570:
--------------------------------------------------------

Commit 906c211ab1f6bacbd29a6d21d8186bb0787173f9 in incubator-geode's branch refs/heads/feature/GEODE-420
from [~jinmeiliao]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-geode.git;h=906c211 ]

GEODE-1570: upgrade spring libraries and fix tests

* updated the spring framework libraries
* updated the spring security libraries and related upgrades
* fixed the tests and uitests


> developer REST API should be secured
> ------------------------------------
>
>                 Key: GEODE-1570
>                 URL: https://issues.apache.org/jira/browse/GEODE-1570
>             Project: Geode
>          Issue Type: Sub-task
>          Components: rest (dev), security
>            Reporter: Swapnil Bawaskar
>
> The developer REST API should require authentication when security is enabled. For authorization,
the implementation should use the new Resource:Operation permissions API that is used by JMX.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message