geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Darrel Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (GEODE-1356) DataAsAddress should not be used in comments and strings
Date Wed, 11 May 2016 17:30:13 GMT

     [ https://issues.apache.org/jira/browse/GEODE-1356?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Darrel Schneider resolved GEODE-1356.
-------------------------------------
       Resolution: Fixed
    Fix Version/s: 1.0.0-incubating.M3

fixed in revision: http://git-wip-us.apache.org/repos/asf/incubator-geode/commit/4d522605

> DataAsAddress should not be used in comments and strings
> --------------------------------------------------------
>
>                 Key: GEODE-1356
>                 URL: https://issues.apache.org/jira/browse/GEODE-1356
>             Project: Geode
>          Issue Type: Bug
>          Components: offheap
>            Reporter: Darrel Schneider
>            Assignee: Darrel Schneider
>            Priority: Trivial
>             Fix For: 1.0.0-incubating.M3
>
>
> The offheap implementation used to have a class named DataAsAddress.
> It no longer does. But we still have some places in the code that use this name.
> For example:
> UnsupportedOperationException("Did not expect DataAsAddress to be compressed");
> should be changed to:
> UnsupportedOperationException("Did not expect encoded address to be compressed");
> Another:
>         // else it is DataAsAddress. This code just returns it as prepared.
> should be:
>         // else it is has no refCount so just return it as prepared.
> Also the method: getSerializedLengthFromDataAsAddress should be renamed (or removed since
it is deadcode).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message