geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Darrel Schneider (JIRA)" <>
Subject [jira] [Created] (GEODE-1356) DataAsAddress should not be used in comments and strings
Date Thu, 05 May 2016 22:57:12 GMT
Darrel Schneider created GEODE-1356:

             Summary: DataAsAddress should not be used in comments and strings
                 Key: GEODE-1356
             Project: Geode
          Issue Type: Bug
          Components: offheap
            Reporter: Darrel Schneider

The offheap implementation used to have a class named DataAsAddress.
It no longer does. But we still have some places in the code that use this name.
For example:
UnsupportedOperationException("Did not expect DataAsAddress to be compressed");
should be changed to:
UnsupportedOperationException("Did not expect encoded address to be compressed");

        // else it is DataAsAddress. This code just returns it as prepared.
should be:
        // else it is has no refCount so just return it as prepared.
Also the method: getSerializedLengthFromDataAsAddress should be renamed (or removed since
it is deadcode).

This message was sent by Atlassian JIRA

View raw message