geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony Baker (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-1259) Required gradle is 2.3 but the wrapper is targeting 2.8
Date Wed, 20 Apr 2016 00:05:25 GMT

    [ https://issues.apache.org/jira/browse/GEODE-1259?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15248983#comment-15248983
] 

Anthony Baker commented on GEODE-1259:
--------------------------------------

The minimum version is checked in settings.gradle.  The gradlew scripts need updates as follows:

1) Update the url reference in geode-assembly/src/src/dist/gradlew to point to the specified
gradle version.
2) Add a closure to explicitly configure the wrapper plugin to generate a plugin at the specified
gradle version.

The latest gradle (as of 4/19) is 2.12.  I've only tested with v2.10.

> Required gradle is 2.3 but the wrapper is targeting 2.8
> -------------------------------------------------------
>
>                 Key: GEODE-1259
>                 URL: https://issues.apache.org/jira/browse/GEODE-1259
>             Project: Geode
>          Issue Type: Bug
>          Components: build
>            Reporter: Roman Shaposhnik
>             Fix For: 1.0.0-incubating.M3
>
>
> This needs to be fixed since Gradle 2.7 (and I suspect earlier versions) are failing
the build with a very cryptic notice.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message