geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <>
Subject [jira] [Commented] (GEODE-217) Update DUnit framework to JUnit 4
Date Mon, 14 Dec 2015 18:06:46 GMT


ASF subversion and git services commented on GEODE-217:

Commit afed665770187d554f24ca84670cbc6a02c9d35e in incubator-geode's branch refs/heads/feature/GEODE-217
from []
[;h=afed665 ]

Merge remote-tracking branch 'origin/develop' into feature/GEODE-217

> Update DUnit framework to JUnit 4
> ---------------------------------
>                 Key: GEODE-217
>                 URL:
>             Project: Geode
>          Issue Type: Improvement
>          Components: tests
>            Reporter: Kirk Lund
>            Assignee: Kirk Lund
> DUnit tests are currently limited to JUnit 3.8 syntax and functionality. Geode developers
would like to be able to use JUnit 4.0 syntax and functionality including Rules.
> Given the large number of DUnit tests it's probably more feasible to introduce a new
DUnit framework in package com.gemstone.gemfire.test.dunit in the gemfire-core project. Then
DUnit tests can be migrated one at a time from using the old implementation in package dunit.*
to using the new one.

This message was sent by Atlassian JIRA

View raw message