geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Bretl (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GEODE-5) Check gradle version when running build
Date Wed, 03 Jun 2015 18:17:38 GMT

     [ https://issues.apache.org/jira/browse/GEODE-5?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mark Bretl updated GEODE-5:
---------------------------
    Attachment: GEODE-5-2.patch

Small update to the patch I will check-in.

I created minimumGradleVersion property so future changes only need to modify version in one
location.

> Check gradle version when running build
> ---------------------------------------
>
>                 Key: GEODE-5
>                 URL: https://issues.apache.org/jira/browse/GEODE-5
>             Project: Geode
>          Issue Type: Improvement
>    Affects Versions: 1.0.0-incubating
>            Reporter: Anthony Baker
>            Assignee: Mark Bretl
>            Priority: Minor
>              Labels: build
>         Attachments: GEODE-5-1.patch, GEODE-5-2.patch
>
>
> Gradle behavior is sometimes version-dependent.  When not using the supplied gradle wrapper
scripts the build should check to ensure that the gradle version is at least 2.3.  If the
gradle version is < 2.3 the build should fail with a nice message.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message