geode-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-5) Check gradle version when running build
Date Thu, 04 Jun 2015 18:35:38 GMT

    [ https://issues.apache.org/jira/browse/GEODE-5?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14573344#comment-14573344
] 

ASF subversion and git services commented on GEODE-5:
-----------------------------------------------------

Commit b5e02b6fa9bdca2df75fb7355b8c6a0c4bf64c92 in incubator-geode's branch refs/heads/develop
from mbretl
[ https://git-wip-us.apache.org/repos/asf?p=incubator-geode.git;h=b5e02b6 ]

[GEODE-5] Add Gradle version check and fail if not using minimum Gradle version.

Tested by running build with Gradle 2.2.1, which fails, and with Gradle wrapper, which runs
successfully.
Reviewed by: AMB


> Check gradle version when running build
> ---------------------------------------
>
>                 Key: GEODE-5
>                 URL: https://issues.apache.org/jira/browse/GEODE-5
>             Project: Geode
>          Issue Type: Improvement
>    Affects Versions: 1.0.0-incubating
>            Reporter: Anthony Baker
>            Assignee: Mark Bretl
>            Priority: Minor
>              Labels: build
>             Fix For: 1.0.0-incubating
>
>         Attachments: GEODE-5-1.patch, GEODE-5-2.patch
>
>
> Gradle behavior is sometimes version-dependent.  When not using the supplied gradle wrapper
scripts the build should check to ensure that the gradle version is at least 2.3.  If the
gradle version is < 2.3 the build should fail with a nice message.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message