geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Kevo <mario.k...@est.tech>
Subject Lucene upgrade
Date Mon, 04 Nov 2019 08:05:29 GMT
Hi geode dev,

I'm working on upgrade lucene to a newer version. (
https://issues.apache.org/jira/browse/GEODE-7309)

I followed instruction from 
https://cwiki.apache.org/confluence/display/GEODE/Upgrading+to+Lucene+7.1.0
Also add some other changes that is needed for lucene 8.2.0.

I found some problems with tests:
 * geode-
   lucene/src/test/java/org/apache/geode/cache/lucene/internal/distribu
   ted/DistributedScoringJUnitTest.java:  


 * geode-lucene/src/upgradeTest/java/org/apache/geode/cache/lucene/RollingUpgradeQueryReturnsCorrectResultsAfterClientAndServersAreRolledOver.java:
 * geode-lucene/src/upgradeTest/java/org/apache/geode/cache/lucene/RollingUpgradeQueryReturnsCorrectResultAfterTwoLocatorsWithTwoServersAreRolled.java:
 * ./geode-lucene/src/upgradeTest/java/org/apache/geode/cache/lucene/RollingUpgradeQueryReturnsCorrectResultsAfterServersRollOverOnPartitionRegion.java:
 * ./geode-lucene/src/upgradeTest/java/org/apache/geode/cache/lucene/RollingUpgradeQueryReturnsCorrectResultsAfterServersRollOverOnPersistentPartitionRegion.java:

      -> failed due to 
Caused by: org.apache.lucene.index.IndexFormatTooOldException: Format
version is not supported (resource
BufferedChecksumIndexInput(segments_1)): 6 (needs to be between 7 and
9). This version of Lucene only supports indexes created with release
6.0 and later.
	at
org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:21
3)
	at
org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:305)
	at
org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:289)
	at
org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:846)
	at
org.apache.geode.cache.lucene.internal.IndexRepositoryFactory.finishCom
putingRepository(IndexRepositoryFactory.java:123)
	at
org.apache.geode.cache.lucene.internal.IndexRepositoryFactory.computeIn
dexRepository(IndexRepositoryFactory.java:66)
	at
org.apache.geode.cache.lucene.internal.PartitionedRepositoryManager.com
puteRepository(PartitionedRepositoryManager.java:151)
	at
org.apache.geode.cache.lucene.internal.PartitionedRepositoryManager.lam
bda$computeRepository$1(PartitionedRepositoryManager.java:170)
	... 16 more


 * geode-lucene/src/upgradeTest/java/org/apache/geode/cache/lucene/RollingUpgradeQueryReturnsCorrectResultsAfterClientAndServersAreRolledOverAllBucketsCreated.java:

      -> failed with the same exception as previous tests


I found this on web 
https://stackoverflow.com/questions/47454434/solr-indexing-issue-after-upgrading-from-4-7-to-7-1
, but not have an idea how to proceed with that.

Does anyone has any idea how to fix it?

BR,
Mario




Mime
View raw message