geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Smith <dsm...@pivotal.io>
Subject Re: What tomcat8 is Geode using?
Date Mon, 28 Oct 2019 23:24:38 GMT
To be clear, we are not actually shipping tomcat with geode. But we do
compile and test our session replication modules against multiple versions
of tomcat. We test against all the versions listed in that
DependencyContraints.groovy file:

    deps.put("tomcat6.version", "6.0.37")
    deps.put("tomcat7.version", "7.0.90")
    deps.put("tomcat8.version", "8.5.34")
    deps.put("tomcat9.version", "9.0.12")

I think all of the bits we test against come from maven, but some unit
tests may just use a tomcat jar, vs. some integration tests that unpack a
full tomcat install.
-Dan


On Mon, Oct 28, 2019 at 1:20 PM Robert Houghton <rhoughton@pivotal.io>
wrote:

> Hi Kirk,
>
> Looking at extensions/geode-modules-tomcat8, that version (8.5.34) is what
> we are compiling and testing against in this module.
>
> On Thu, Oct 24, 2019 at 10:55 AM Kirk Lund <klund@apache.org> wrote:
>
> > What actual artifacts does this refer to in DependencyConstraints.groovy?
> >
> >     deps.put("tomcat8.version", "8.5.34")
> >
> > Does this mean we are using
> >
> https://mvnrepository.com/artifact/org.apache.tomcat/tomcat-catalina/8.5.34
> > or some download?
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message