geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darrel Schneider <dschnei...@pivotal.io>
Subject Re: Backward compatibility issue in 1.10
Date Thu, 19 Sep 2019 14:49:50 GMT
I agree that it is not needed in 1.10 since this interface is not meant to
be implemented by users

On Thu, Sep 19, 2019 at 5:25 AM Jacob Barrett <jbarrett@pivotal.io> wrote:

> Good find. I agree that it’s fine since it’s not a user implemented
> interface.
>
> > On Sep 19, 2019, at 1:20 AM, Alberto Bustamante Reyes
> <alberto.bustamante.reyes@est.tech> wrote:
> >
> > Hi,
> >
> > During PR review of GEODE-6871 it was found that GEODE-5222 introduced a
> backward compatibility issue by adding a new method to a public interface
> without providing a default implementation.
> > According to comments in the PR, although the impacted interface
> (DiskStoreMXBean) is public, it should not be implemented by applications,
> so the risk of breaking backward compatibility is low, but it exists.
> >
> > Do you think this issue should be fixed in 1.10?
> >
> > BR/
> >
> > Alberto
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message