geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Barrett <jbarr...@pivotal.io>
Subject Re: [VOTE] Apache Geode 1.10.0.RC2
Date Wed, 25 Sep 2019 19:29:17 GMT


> On Sep 25, 2019, at 12:26 PM, Owen Nichols <onichols@pivotal.io> wrote:
> 
> ⚠️ to run my spring boot client for above test, I had to manually add compile 'io.micrometer:micrometer-core:1.2.0'
, otherwise local region creation blows up with “java.lang.NoSuchMethodError” due to spring-boot-starter
pulling in micrometer 1.0.3 by default.  This never happened with previous versions.  Not
sure if this is outside Geode’s control, but it felt like a poor out-of-the-box experience...


Is your spring app including geode via maven/gradle dependency management? This may be pointing
to a greater issue with dependency exports in the new release's POM. 

-Jake


Mime
View raw message