Here is my settings. I only set ‘inherit project compile path’ when it is needed.
image.png

On Thu, Jun 20, 2019 at 1:28 PM Murtuza Boxwala <mboxwala@pivotal.io> wrote:
Eric,

Can you please share a screen shot of your gradle preferences in Intellij (I attached mine, too).  I tried Jens’ solution and used the Gradle builder and the IntelliJ test runner and it works okay, but I don’t think I am getting the advantage of intellij’s continuous incremental building in the background.  This adds 10’ish seconds to my TDD loop because it has to keep compiling geode-core:test.

I saw the options to ‘inherit project compile path’ but there were tons of modules and I am not sure if I have to set it on all of them.

If anyone else has build and test working with IntelliJ and knows what I am doing wrong, please chime in. 

Thanks,
Murtuza

On Jun 6, 2019, at 8:12 PM, Eric Shu <eshu@pivotal.io> wrote:

I worked around this issue by choosing Inherit project compile output path.

On Thu, Jun 6, 2019 at 3:16 PM Jens Deppe <jdeppe@pivotal.io> wrote:

I have only experienced this when I switch to building with IntelliJ (it is
also dependent on what Intellij deems necessary to build). Building with
gradle has never produced this. My setup is to build with gradle but run
tests with IntelliJ. I've never had to do any kind of re-import for this.

Re-import feels somewhat like an OS re-install. My suggestion would be: do
a clean CLI gradle build first. Then do a full project rebuild in IJ.

--Jens

On Thu, Jun 6, 2019 at 12:06 PM Ryan McMahon <mcmellawatt@apache.org>
wrote:

Fair warning - some have wiped their .idea file and it works temporarily,
but inevitably will return.  I would recommend the setting changes as
described above if it recurs.

Ryan

On Thu, Jun 6, 2019 at 12:04 PM Peter Tran <ptran@pivotal.io> wrote:

Awesome - a wipe of my .idea file worked. Thank you!

On Thu, Jun 6, 2019 at 2:54 PM Jacob Barrett <jbarrett@pivotal.io>
wrote:

This seems to happen frequently with 2019.1. The easiest way I found
to
fix this was to start over with the IJ project.  Some have had luck
switching between the gradle builder and the IJ builder in the cradle
configuration panel.

On Jun 6, 2019, at 11:47 AM, Peter Tran <ptran@pivotal.io> wrote:

Hello,

Has anyone had an issue in IntelliJ running tests with the error:

"Cannot start compilation: the output path is not specified for
module"

I setup intelliJ using the BUILDING.md instructions and haven't
come
across
this problem. I haven't updated intelliJ since the last time I ran
tests
successfully. I haven't changed my JDK and am experiencing it on
develop

Thanks