geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Galen O'Sullivan" <gosulli...@pivotal.io>
Subject Re: Gradle build broken?
Date Wed, 23 Jan 2019 17:38:14 GMT
I tried cleaning as well. It turns out that the directory I needed to
remove was `~/.m2`. I guess the package cache was corrupted. Transient
failure?

On Tue, Jan 22, 2019 at 5:49 PM Galen O'Sullivan <gosullivan@pivotal.io>
wrote:

> I'm getting the following failure building Geode on the latest develop.
> I've tried `rm -r .gradle ~/.gradle`, to no avail. Any ideas?
>
> Thanks,
> Galen
>
> ---
>
> ./gradlew dev
> > Task :geode-core:compileIntegrationTestJava FAILED
>
> FAILURE: Build failed with an exception.
>
> * What went wrong:
> Execution failed for task ':geode-core:compileIntegrationTestJava'.
> > Could not resolve all files for configuration
> ':geode-core:integrationTestCompileClasspath'.
>    > Could not find log4j-core-tests.jar
> (org.apache.logging.log4j:log4j-core:2.11.1).
>      Searched in the following locations:
>
> file:/Users/gosullivan/.m2/repository/org/apache/logging/log4j/log4j-core/2.11.1/log4j-core-2.11.1-tests.jar
>    > Could not find log4j-core-test-sources.jar
> (org.apache.logging.log4j:log4j-core:2.11.1).
>      Searched in the following locations:
>
> file:/Users/gosullivan/.m2/repository/org/apache/logging/log4j/log4j-core/2.11.1/log4j-core-2.11.1-test-sources.jar
>
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or
> --debug option to get more log output. Run with --scan to get full insights.
>
> * Get more help at https://help.gradle.org
>
> Deprecated Gradle features were used in this build, making it incompatible
> with Gradle 6.0.
> Use '--warning-mode all' to show the individual deprecation warnings.
> See
> https://docs.gradle.org/5.0/userguide/command_line_interface.html#sec:command_line_warnings
>
> BUILD FAILED in 24s
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message