geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Blum <jb...@pivotal.io>
Subject Re: Concerning Apache Geode 1.7.0
Date Wed, 05 Sep 2018 21:22:48 GMT
Doesn't the pending release branch, or something, publish (build) snapshot
artifacts to a snapshot repo somewhere?

How do/can users test out the upcoming bits (that is nightly build snapshot
artifacts)?


On Wed, Sep 5, 2018 at 2:13 PM, Nabarun Nag <nnag@pivotal.io> wrote:

> @John, the [DISCUSS] mail for the new branch has not been sent yet. The
> branch you are looking at is an old one that was abandoned few months ago.
> The new branch is undergoing some preliminary tests on my local machine
> before getting published to the world. A mail will be sent out as soon as
> the branch is ready.
>
> Regards
> Nabarun Nag
>
>
> On Wed, Sep 5, 2018 at 2:10 PM John Blum <jblum@pivotal.io> wrote:
>
> > I see that the branch for Apache Geode 1.7.0 (release/1.7.0 [1]) has been
> > created in preparation for the upcoming the 1.7 release.
> >
> > I am trying to get an early sense/feel for the required changes in SDG
> when
> > I rebase it on 1.7.
> >
> > Previously, I was able to obtain Geode snapshots from...
> >
> >
> > <repository>
> >    <id>apache-snapshots</id
> >    <url>https://repository.apache.org/content/repositories/snapshots
> </url
> > </repository>
> >
> >
> > But currently, Maven is unable to resolve the 1.7 JARs....
> >
> >
> > $ mvn dependency:resolve
> > [INFO] Scanning for projects...
> > [INFO]
> > [INFO] -------------< org.springframework.data:spring-data-geode
> > >-------------
> > [INFO] Building Spring Data Geode 2.2.0.BUILD-SNAPSHOT
> > [INFO] --------------------------------[ jar
> > ]---------------------------------
> > [WARNING] The POM for org.apache.geode:geode-core:jar:1.7.0 is missing,
> no
> > dependency information available
> > [WARNING] The POM for org.apache.geode:geode-cq:jar:1.7.0 is missing, no
> > dependency information available
> > [WARNING] The POM for org.apache.geode:geode-lucene:jar:1.7.0 is
> missing,
> > no dependency information available
> > [WARNING] The POM for org.apache.geode:geode-wan:jar:1.7.0 is missing,
> no
> > dependency information available
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] BUILD FAILURE
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time: 0.617 s
> > [INFO] Finished at: 2018-09-05T14:07:30-07:00
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] Failed to execute goal on project spring-data-geode: Could not
> > resolve dependencies for project
> > org.springframework.data:spring-data-geode:jar:2.2.0.BUILD-SNAPSHOT:
> *The
> > following artifacts could not be resolved*:
> > org.apache.geode:geode-core:jar:1.7.0, org.apache.geode:geode-cq:jar:
> 1.7.0,
> > org.apache.geode:geode-lucene:jar:1.7.0,
> > org.apache.geode:geode-wan:jar:1.7.0: Failure to find
> > org.apache.geode:geode-core:jar:1.7.0 *in
> > https://repository.apache.org/content/repositories/snapshots
> > <https://repository.apache.org/content/repositories/snapshots>* was
> cached
> > in the local repository, resolution will not be reattempted until the
> > update interval of apache-snapshots has elapsed or updates are forced ->
> > [Help 1]
> >
> >
> > Is this the correct repo and are the 1.7 snapshots currently available?
> >
> > Thanks,
> >
> > --
> > -John
> >
> > [1] https://github.com/apache/geode/tree/release/1.7.0
> >
>



-- 
-John
john.blum10101 (skype)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message