geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kirk Lund <kl...@apache.org>
Subject Revert recent Gradle upgrade
Date Thu, 21 Jun 2018 19:19:51 GMT
I think we should revert the recent Gradle upgrade. This change apparently
causes IntelliJ to not be able to build Geode which prevents us from
running any Tests in the IDE.

I'd prefer to fix how IntelliJ works with our project but we cannot be
without the ability to debug tests. I don't know enough to fix this problem.

If we can't fix the ability to run Tests in the IDE, then we should revert
this commit:

commit 7685375ea7229ad0e0fc9ea188cccfa56ff7d8ef
Author: Robert Houghton <32176082+rhoughton-pivot@users.noreply.github.com>
Date:   Tue Jun 19 08:28:51 2018 -0700

    GEODE-4791: Enable gradle 4.8 for features and futureproofing (#2050)

    Enable:
    * Java 10 (when ready)
    * remove deprecated configuration settings
    * build-cache
    * incremental
    * Update classpath/srcpath logic

    Disable:
    * parallel (to fix Tomcat tests bind issues)

    Signed-off-by: Robert Houghton <rhoughton@pivotal.io>
    Signed-off-by: Jens Deppe <jdeppe@pivotal.io>
    Signed-off-by: Robert Houghton <rhoughton@pivotal.io>
    Signed-off-by: Jens Deppe <jdeppe@pivotal.io>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message