geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Secrist <msecr...@pivotal.io>
Subject Using partition resolver via gfsh command vs XML config
Date Tue, 02 Jan 2018 16:57:48 GMT
Hi all,
 I'm curious why I'd be running into issues using the gfsh command to
create a region using a partition resolver, yet can do so using XML
configuration. I've tried a couple of different combinations.

 I have a partition resolver class that is packaged in a JAR file. I tried
the following:

   1. Deployed jar file using 'deploy --j' [success], created region using
   command 'create region --name=BookOrder --type=PARTITION
   --partition-resolver=....' [Failed]
   - io.pivotal.bookshop.partitions.CustomerPartitionResolverPartitionResolver
   is an invalid Partition Resolver
   2. Configured region from gfsh using StringPrefixPartitionResolver for
   partition resolver [Success]
   3. Un-deployed jar file. Used traditional classpath and XML
   configuration [Success]
   4. Deployed jar file using 'deploy' [Success] Configure region with
   partition resolver in XML file [Success]

If it wasn't for the fact that attempt #2 was successful, I'd believe that
maybe it wasn't possible to use the gfsh command to configure a region with
partition resolver. I'm frankly at a loss to understand why this wouldn't
work.

This is using GemFire 9.2.1 bits by the way...

Thoughts?
-- 

*Mark Secrist | Director, **Global Education Delivery*

msecrist@pivotal.io

970.214.4567 Mobile

  *pivotal.io <http://www.pivotal.io/>*

Follow Us: Twitter <http://www.twitter.com/pivotal> | LinkedIn
<http://www.linkedin.com/company/pivotalsoftware> | Facebook
<http://www.facebook.com/pivotalsoftware> | YouTube
<http://www.youtube.com/gopivotal> | Google+
<https://plus.google.com/105320112436428794490>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message