geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Deppe <jde...@pivotal.io>
Subject Re: geode and open JDK / newer version of java
Date Wed, 18 Oct 2017 14:44:46 GMT
Hi Roi,

We've spent a little time doing some cursory testing with Java 9 and there
are definitely some issues:

- Compilation requires additional JVM args because of the new
modularization in Java 9.
- A few lambda syntaxes in tests need to be adjusted.
- Some tests fail due to powermock issues.
- Using a distro built with Java 1.8, but running on Java 9, I was not able
to start locators or servers.

I don't remember the exact version used, but I believe it was an OpenJDK
downloaded just a few days before the official release.

--Jens

On Wed, Oct 18, 2017 at 2:51 AM, Roi Apelker <Roi.Apelker@amdocs.com> wrote:

> Hi,
>
> Has anyone tried to operate GEODE with open JDK - any version - rather
> than Oracle's JDK?
>
> Has anyone tried to operate GEODE with open JDK - specifically version 9
> (released Sep 21 2017)?
>
> What about Oracle's version 9?
>
> Any migration issues, problems etc. ?
>
> Thanks,
>
> Roi
> This message and the information contained herein is proprietary and
> confidential and subject to the Amdocs policy statement,
>
> you may review at https://www.amdocs.com/about/email-disclaimer <
> https://www.amdocs.com/about/email-disclaimer>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message