geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stolz <mst...@pivotal.io>
Subject Re: [VOTE] Apache Geode release - v1.2.1 RC1
Date Tue, 05 Sep 2017 18:04:01 GMT
GEODE-3249 is a breaking change to the client/server protocol, but it has a
property that can override whether or not to turn the breaking change on.

The plan was to release Geode 1.2.1 with the breaking change turned on, but
I spent a lot of time thinking about this over the weekend, and I came to
the conclusion that introducing a *breaking change in a patch release* is a
bad idea. Protocol breaking changes should really only occur in major
releases.

That said, because this is an important change for some users, the right
thing to do is probably to set the default for the controlling property to
enable backward compatibility, and then the users who want the change can
OPT-IN, rather than requiring users who are taking the patch release and
don't want the breaking change having to OPT-OUT.

We can switch that default behavior on the next major release.


--
Mike Stolz
Principal Engineer, GemFire Product Manager
Mobile: +1-631-835-4771

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message