geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jared Stewart (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GEODE-2966) Refactor LauncherLifecycleCommands
Date Thu, 01 Jun 2017 16:08:04 GMT

     [ https://issues.apache.org/jira/browse/GEODE-2966?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jared Stewart updated GEODE-2966:
---------------------------------
    Fix Version/s: 1.3.0

> Refactor LauncherLifecycleCommands
> ----------------------------------
>
>                 Key: GEODE-2966
>                 URL: https://issues.apache.org/jira/browse/GEODE-2966
>             Project: Geode
>          Issue Type: Sub-task
>          Components: gfsh, management
>            Reporter: Jared Stewart
>            Assignee: Jared Stewart
>             Fix For: 1.3.0
>
>
> LauncherLifecycleCommands is over 2000 lines of code, and could be made a lot more readable
by introducing proper OO abstraction.  There are also many private static final strings like
{{CliStrings.START_LOCATOR__MEMBER_NAME}} that could be made shorter and more contextual,
e.g. {{StartLocatorCommand.MEMBER_NAME}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message