geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEODE-2966) Refactor LauncherLifecycleCommands
Date Thu, 01 Jun 2017 16:07:04 GMT

    [ https://issues.apache.org/jira/browse/GEODE-2966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033214#comment-16033214
] 

ASF subversion and git services commented on GEODE-2966:
--------------------------------------------------------

Commit 9046c8dcd3bf530997fbb374085f1c1213db15e3 in geode's branch refs/heads/develop from
[~jstewart]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=9046c8d ]

GEODE-2966: RefactorLauncherLifecycleCommands

 - Extract several commands into their own classes.
 - Extract utility methods into their own classes.
 - Rename AbstractCommandsSupport to GfshCommand, and convert it from an abstract class to
an interface


> Refactor LauncherLifecycleCommands
> ----------------------------------
>
>                 Key: GEODE-2966
>                 URL: https://issues.apache.org/jira/browse/GEODE-2966
>             Project: Geode
>          Issue Type: Sub-task
>          Components: gfsh, management
>            Reporter: Jared Stewart
>            Assignee: Jared Stewart
>
> LauncherLifecycleCommands is over 2000 lines of code, and could be made a lot more readable
by introducing proper OO abstraction.  There are also many private static final strings like
{{CliStrings.START_LOCATOR__MEMBER_NAME}} that could be made shorter and more contextual,
e.g. {{StartLocatorCommand.MEMBER_NAME}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message