geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stolz <mst...@pivotal.io>
Subject Re: [jira] [Updated] (GEODE-2892) Add sizeOnServer and isEmptyOnServer to Region
Date Thu, 01 Jun 2017 19:10:30 GMT
sizeOnServer( ) is less confusing than size(boolean localSize).

--
Mike Stolz
Principal Engineer, GemFire Product Manager
Mobile: +1-631-835-4771

On Wed, May 31, 2017 at 8:09 PM, Fred Krone (JIRA) <jira@apache.org> wrote:

>
>      [ https://issues.apache.org/jira/browse/GEODE-2892?page=
> com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
>
> Fred Krone updated GEODE-2892:
> ------------------------------
>     Fix Version/s: 1.2.0
>
> > Add sizeOnServer and isEmptyOnServer to Region
> > ----------------------------------------------
> >
> >                 Key: GEODE-2892
> >                 URL: https://issues.apache.org/jira/browse/GEODE-2892
> >             Project: Geode
> >          Issue Type: Sub-task
> >          Components: regions
> >            Reporter: Fred Krone
> >            Assignee: Eric Shu
> >              Labels: storage_2
> >             Fix For: 1.2.0
> >
> >
> > To lower confusion while also not breaking backwards compatibility
> Region needs explicit "onServer" methods.
> > sizeOnServer
> > isEmptyOnServer
> > These could also be named something like size(boolean localSize) to keep
> the API a less wordy.
> > ACCEPTANCE:
> > When a developer uses these methods then the result should be from the
> server-side.   This includes accessor Regions.
> > JavaDocs should be updated accordingly.
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v6.3.15#6346)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message