geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fred Krone (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GEODE-2893) Add containsKeyOnServer and containsValueOnServer to Region
Date Mon, 08 May 2017 20:17:04 GMT

     [ https://issues.apache.org/jira/browse/GEODE-2893?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Fred Krone updated GEODE-2893:
------------------------------
    Description: 
To lower confusion while also not breaking backwards compatibility Region needs explicit "onServer"
methods.

containsKeyOnServer 
containsValueOnServer

These could also be named something like size(boolean localSize) to keep the API a less wordy.

When a developer uses these methods then the result should be from the server-side. 


> Add containsKeyOnServer and containsValueOnServer to Region
> -----------------------------------------------------------
>
>                 Key: GEODE-2893
>                 URL: https://issues.apache.org/jira/browse/GEODE-2893
>             Project: Geode
>          Issue Type: Sub-task
>          Components: regions
>            Reporter: Fred Krone
>
> To lower confusion while also not breaking backwards compatibility Region needs explicit
"onServer" methods.
> containsKeyOnServer 
> containsValueOnServer
> These could also be named something like size(boolean localSize) to keep the API a less
wordy.
> When a developer uses these methods then the result should be from the server-side. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message