geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Bretl <asf.mbr...@gmail.com>
Subject Re: Problems in the gradle idea generated project
Date Tue, 16 May 2017 22:19:06 GMT
Yes, Eclipse can import Gradle projects through the Eclipse Buildship,
https://projects.eclipse.org/projects/tools.buildship. I have not tested
with Geode for verification it can handle some the custom tasks we have.

I think it may be time to not use the Eclipse or Idea plugins from Gradle.
The Gradle plugins came first, however, I think both IDEA and Eclipse have
both surpassed the level of functionality we are getting with the Gradle
plugins.

--Mark

On Tue, May 16, 2017 at 3:13 PM, Bruce Schuchardt <bschuchardt@pivotal.io>
wrote:

> I was refering to the problem introduced by the newer version of gradle.
> I also see Kirk's problem with Idea projects generated by gradle if I try
> to use them.  Should we just get rid of Idea project generation?
>
>
> Le 5/16/2017 à 3:11 PM, Bruce Schuchardt a écrit :
>
>> Yes, just import the gradle project, though I think the same problem
>> exists for eclipse project generation.  Does eclipse have the ability to
>> import gradle projects?
>>
>> Le 5/16/2017 à 3:03 PM, Dan Smith a écrit :
>>
>>> I don't think you actually need to use the gradle idea plugin - I think
>>> that's less up to date than the intellij's support for gradle. Just
>>> import
>>> the project as a gradle project in intellij.
>>>
>>> -Dan
>>>
>>> On Tue, May 16, 2017 at 2:52 PM, Kirk Lund <klund@apache.org> wrote:
>>>
>>> If I use the idea plugin to generate an IntelliJ project for Geode:
>>>>
>>>> $ ./gradlew idea
>>>>
>>>> ...the resulting IntelliJ project contains "5 Problems" involving the
>>>> extensions modules:
>>>>
>>>> *Module geode-modules-session: invalid item
>>>> 'extensions/geode-modules-session-internal' in the dependencies list*
>>>> *Module geode-modules-session: invalid item 'extensions/geode-modules'
>>>> in
>>>> the dependencies list*
>>>> *Module geode-modules-session-internal: invalid item
>>>> 'extensions/geode-modules' in the dependencies list*
>>>> *Module geode-modules-tomcat7: invalid item 'extensions/geode-modules'
>>>> in
>>>> the dependencies list*
>>>> *Module geode-modules-tomcat8: invalid item 'extensions/geode-modules'
>>>> in
>>>> the dependencies list*
>>>>
>>>> This looks like we have some quirk or minor problem in our gradle files
>>>> that doesn't perfectly translate to an IntelliJ project. Any ideas how
>>>> to
>>>> fix the above problems?
>>>>
>>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message