geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ernest Burghardt (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GEODE-2487) SSL should not require external security library
Date Tue, 18 Apr 2017 17:46:41 GMT

     [ https://issues.apache.org/jira/browse/GEODE-2487?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ernest Burghardt updated GEODE-2487:
------------------------------------
    Description: 
Geode Native requires that cryptoImpl library be compiled by the end user to support SSL.
The rational for this has been lost but was likely to avoid either export control, which it
does not, or to make dynamic loading of OpenSSL easier, which I am not sure it does.

Refactor SSL sockets to initialize and use OpenSSL (via ACE_SSL) directly and remove it from
cryptoImpl library. If there is no other purpose for cryptoImpl library then purge it.

  was:
Geode Native requires that securityImpl library be compiled by the end user to support SSL.
The rational for this has been lost but was likely to avoid either export control, which it
does not, or to make dynamic loading of OpenSSL easier, which I am not sure it does.

Refactor SSL sockets to initialize and use OpenSSL (via ACE_SSL) directly and remove it from
securityImpl library. If there is no other purpose for securityImpl library then purge it.


> SSL should not require external security library
> ------------------------------------------------
>
>                 Key: GEODE-2487
>                 URL: https://issues.apache.org/jira/browse/GEODE-2487
>             Project: Geode
>          Issue Type: Bug
>          Components: native client
>            Reporter: Jacob S. Barrett
>
> Geode Native requires that cryptoImpl library be compiled by the end user to support
SSL. The rational for this has been lost but was likely to avoid either export control, which
it does not, or to make dynamic loading of OpenSSL easier, which I am not sure it does.
> Refactor SSL sockets to initialize and use OpenSSL (via ACE_SSL) directly and remove
it from cryptoImpl library. If there is no other purpose for cryptoImpl library then purge
it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message