geode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Swapnil Bawaskar (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (GEODE-2544) gfsh incorrectly reports that tools.jar is required if JAVA_ARGS=-Dgemfire.test.ProcessControllerFactory.DisableAttachApi=true
Date Mon, 13 Mar 2017 16:41:41 GMT

     [ https://issues.apache.org/jira/browse/GEODE-2544?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Swapnil Bawaskar closed GEODE-2544.
-----------------------------------

> gfsh incorrectly reports that tools.jar is required if JAVA_ARGS=-Dgemfire.test.ProcessControllerFactory.DisableAttachApi=true
> ------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: GEODE-2544
>                 URL: https://issues.apache.org/jira/browse/GEODE-2544
>             Project: Geode
>          Issue Type: Bug
>          Components: gfsh
>            Reporter: Kirk Lund
>            Assignee: Kirk Lund
>
> This behavior is incorrect. The ProcessControllerFactory should use FileProcessUtils
instead of AttachProcessUtils without any error or warning.
> {noformat}
> <klund@latvia>/home/klund/latvia/dev/geode [1042]$ export JAVA_ARGS=-Dgemfire.test.ProcessControllerFactory.DisableAttachApi=true
> <klund@latvia>/home/klund/latvia/dev/geode [1044]$ ./geode-assembly/build/install/apache-geode/bin/gfsh
> gfsh>start locator --name=loc1
> Starting a Geode Locator in /export/latvia1/users/klund/dev/geode/loc1...
> An error occurred while attempting to start a Locator in /export/latvia1/users/klund/dev/geode/loc1
on latvia.gemstone.com[10334]: The Attach API classes could not be found on the classpath.
 Please include JDK tools.jar on the classpath or add the JDK tools.jar to the jre/lib/ext
directory.
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message