geode-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From prhomb...@apache.org
Subject [geode] branch develop updated: GEODE-5938: Make dependencies explicit in cq and rebalancer modules. (#2729)
Date Mon, 05 Nov 2018 19:48:18 GMT
This is an automated email from the ASF dual-hosted git repository.

prhomberg pushed a commit to branch develop
in repository https://gitbox.apache.org/repos/asf/geode.git


The following commit(s) were added to refs/heads/develop by this push:
     new 7f657f9  GEODE-5938: Make dependencies explicit in cq and rebalancer modules. (#2729)
7f657f9 is described below

commit 7f657f9646b7d58d44aed2e35e556dd7cf0c6824
Author: Patrick Rhomberg <prhomberg@pivotal.io>
AuthorDate: Mon Nov 5 11:48:09 2018 -0800

    GEODE-5938: Make dependencies explicit in cq and rebalancer modules. (#2729)
---
 geode-cq/build.gradle                              | 29 +++++++++++++++++++++-
 geode-cq/src/test/resources/expected-pom.xml       | 14 +++++++++++
 geode-rebalancer/build.gradle                      | 19 ++++++++------
 .../src/test/resources/expected-pom.xml            | 18 ++++++++++++++
 4 files changed, 71 insertions(+), 9 deletions(-)

diff --git a/geode-cq/build.gradle b/geode-cq/build.gradle
index 0c9e34e..b65e758 100644
--- a/geode-cq/build.gradle
+++ b/geode-cq/build.gradle
@@ -16,7 +16,7 @@
  */
 
 dependencies {
-  compileOnly(project(':geode-core'))
+  compile(project(':geode-core'))
   testCompile(project(':geode-core'))
   testCompile(project(':geode-junit')) {
     exclude module: 'geode-core'
@@ -24,7 +24,34 @@ dependencies {
   integrationTestCompile(project(':geode-dunit')) {
     exclude module: 'geode-core'
   }
+  integrationTestCompile(project(':geode-junit')) {
+    exclude module: 'geode-core'
+  }
+  distributedTestCompile(project(':geode-junit')) {
+    exclude module: 'geode-core'
+  }
   upgradeTestCompile(project(':geode-dunit')) {
     exclude module: 'geode-core'
   }
+  upgradeTestCompile(project(':geode-junit')) {
+    exclude module: 'geode-core'
+  }
+
+  compile('org.apache.logging.log4j:log4j-api:' + project.'log4j.version')
+
+  integrationTestCompile('junit:junit:' + project.'junit.version')
+  integrationTestCompile('org.awaitility:awaitility:' + project.'awaitility.version')
+
+  distributedTestCompile('commons-lang:commons-lang:' + project.'commons-lang.version')
+  distributedTestCompile('junit:junit:' + project.'junit.version')
+  distributedTestCompile('mx4j:mx4j:' + project.'mx4j.version')
+  distributedTestCompile('org.assertj:assertj-core:' + project.'assertj-core.version')
+  distributedTestCompile('org.awaitility:awaitility:' + project.'awaitility.version')
+  distributedTestCompile('org.hamcrest:hamcrest-all:' + project.'hamcrest-all.version')
+  distributedTestCompile('org.hamcrest:hamcrest-core:' + project.'hamcrest-all.version')
+  distributedTestCompile('org.hamcrest:hamcrest-library:' + project.'hamcrest-all.version')
+
+  upgradeTestCompile('junit:junit:' + project.'junit.version')
+  upgradeTestCompile('org.awaitility:awaitility:' + project.'awaitility.version')
+  upgradeTestCompile('org.mockito:mockito-core:' + project.'mockito-core.version')
 }
diff --git a/geode-cq/src/test/resources/expected-pom.xml b/geode-cq/src/test/resources/expected-pom.xml
index bc9c769..aeab64a 100644
--- a/geode-cq/src/test/resources/expected-pom.xml
+++ b/geode-cq/src/test/resources/expected-pom.xml
@@ -34,4 +34,18 @@
     <developerConnection>scm:git:https://github.com:apache/geode.git</developerConnection>
     <url>https://github.com/apache/geode</url>
   </scm>
+  <dependencies>
+    <dependency>
+      <groupId>org.apache.geode</groupId>
+      <artifactId>geode-core</artifactId>
+      <version>1.8.0-SNAPSHOT</version>
+      <scope>compile</scope>
+    </dependency>
+    <dependency>
+      <groupId>org.apache.logging.log4j</groupId>
+      <artifactId>log4j-api</artifactId>
+      <version>2.11.0</version>
+      <scope>compile</scope>
+    </dependency>
+  </dependencies>
 </project>
diff --git a/geode-rebalancer/build.gradle b/geode-rebalancer/build.gradle
index 67f59c2..035930d 100644
--- a/geode-rebalancer/build.gradle
+++ b/geode-rebalancer/build.gradle
@@ -16,20 +16,23 @@
  */
 
 dependencies {
-  compileOnly(project(':geode-common'))
-  compileOnly(project(':geode-core'))
+  compile(project(':geode-common'))
+  compile(project(':geode-core'))
+  testCompile(project(':geode-core'))
+  integrationTestCompile(project(':geode-junit')) {
+    exclude module: 'geode-core'
+  }
 
+  compile('org.apache.logging.log4j:log4j-api:' + project.'log4j.version')
   compile('org.springframework:spring-context:' + project.'springframework.version') {
     exclude module: 'spring-beans'
     exclude module: 'spring-expression'
     exclude module: 'spring-aop'
   }
 
-  testCompile(project(':geode-core'))
-
+  integrationTestCompile('junit:junit:' + project.'junit.version')
   integrationTestCompile('org.awaitility:awaitility:' + project.'awaitility.version')
-  // Only needed for category Flaky by Gradle
-  integrationTestCompile(project(':geode-junit')) {
-    exclude module: 'geode-core'
-  }
+  integrationTestCompile('org.hamcrest:hamcrest-all:' + project.'hamcrest-all.version')
+  integrationTestCompile('org.hamcrest:hamcrest-core:' + project.'hamcrest-all.version')
+  integrationTestCompile('org.hamcrest:hamcrest-library:' + project.'hamcrest-all.version')
 }
diff --git a/geode-rebalancer/src/test/resources/expected-pom.xml b/geode-rebalancer/src/test/resources/expected-pom.xml
index 5028aef..a693457 100644
--- a/geode-rebalancer/src/test/resources/expected-pom.xml
+++ b/geode-rebalancer/src/test/resources/expected-pom.xml
@@ -36,6 +36,24 @@
   </scm>
   <dependencies>
     <dependency>
+      <groupId>org.apache.logging.log4j</groupId>
+      <artifactId>log4j-api</artifactId>
+      <version>2.11.0</version>
+      <scope>compile</scope>
+    </dependency>
+    <dependency>
+      <groupId>org.apache.geode</groupId>
+      <artifactId>geode-common</artifactId>
+      <version>1.8.0-SNAPSHOT</version>
+      <scope>compile</scope>
+    </dependency>
+    <dependency>
+      <groupId>org.apache.geode</groupId>
+      <artifactId>geode-core</artifactId>
+      <version>1.8.0-SNAPSHOT</version>
+      <scope>compile</scope>
+    </dependency>
+    <dependency>
       <groupId>org.springframework</groupId>
       <artifactId>spring-context</artifactId>
       <version>4.3.18.RELEASE</version>


Mime
View raw message