geode-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From upthewatersp...@apache.org
Subject [53/70] incubator-geode git commit: GEODE-802: Add cq, wan projects to the gradle build
Date Thu, 28 Jan 2016 18:13:55 GMT
GEODE-802: Add cq, wan projects to the gradle build

The gemfire-cq and gemfire-wan projects will now be built along with
everything else.


Project: http://git-wip-us.apache.org/repos/asf/incubator-geode/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-geode/commit/56bbcbe2
Tree: http://git-wip-us.apache.org/repos/asf/incubator-geode/tree/56bbcbe2
Diff: http://git-wip-us.apache.org/repos/asf/incubator-geode/diff/56bbcbe2

Branch: refs/heads/develop
Commit: 56bbcbe27f59055f8f2fe7606b14c2de93025f2a
Parents: 2b78134
Author: Dan Smith <upthewaterspout@apache.org>
Authored: Wed Jan 20 13:34:21 2016 -0800
Committer: Dan Smith <upthewaterspout@apache.org>
Committed: Fri Jan 22 14:45:24 2016 -0800

----------------------------------------------------------------------
 gemfire-assembly/build.gradle | 10 ++++++++++
 gemfire-cq/build.gradle       |  1 -
 settings.gradle               |  2 ++
 3 files changed, 12 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-geode/blob/56bbcbe2/gemfire-assembly/build.gradle
----------------------------------------------------------------------
diff --git a/gemfire-assembly/build.gradle b/gemfire-assembly/build.gradle
index 0b922d5..834413e 100755
--- a/gemfire-assembly/build.gradle
+++ b/gemfire-assembly/build.gradle
@@ -53,6 +53,8 @@ dependencies {
   archives project(':gemfire-web')
   archives project(':gemfire-web-api')
   archives project(':gemfire-pulse')
+  archives project(':gemfire-wan')
+  archives project(':gemfire-cq')
 
   testCompile project(path: ':gemfire-junit', configuration: 'testOutput')
   testCompile project(path: ':gemfire-core', configuration: 'testOutput')
@@ -145,6 +147,8 @@ def cp = {
       it.contains('hbase') ||
       it.contains('jgroups') ||
       it.contains('netty') ||
+      it.contains('gemfire-wan') ||
+      it.contains('gemfire-cq') ||
       
       // dependencies from gemfire-lucene
       it.contains('lucene-analyzers-common') ||
@@ -249,6 +253,12 @@ distributions {
         from project(":gemfire-joptsimple").configurations.runtime
         from project(":gemfire-joptsimple").configurations.archives.allArtifacts.files
 
+        from project(":gemfire-wan").configurations.runtime
+        from project(":gemfire-wan").configurations.archives.allArtifacts.files
+
+        from project(":gemfire-cq").configurations.runtime
+        from project(":gemfire-cq").configurations.archives.allArtifacts.files
+
         from project(":gemfire-core").configurations.runtime
         // Copying from provided configuration is only for supporting Spring Data GemFire.
         // If there are more dependencies added to provided configuration, this will need

http://git-wip-us.apache.org/repos/asf/incubator-geode/blob/56bbcbe2/gemfire-cq/build.gradle
----------------------------------------------------------------------
diff --git a/gemfire-cq/build.gradle b/gemfire-cq/build.gradle
index ed92c42..eba2539 100644
--- a/gemfire-cq/build.gradle
+++ b/gemfire-cq/build.gradle
@@ -1,6 +1,5 @@
 dependencies {
   provided project(':gemfire-core')
-  provided project(':gemfire-test')
   provided project(path: ':gemfire-core', configuration: 'testOutput')
   provided project(path: ':gemfire-junit', configuration: 'testOutput')
 }

http://git-wip-us.apache.org/repos/asf/incubator-geode/blob/56bbcbe2/settings.gradle
----------------------------------------------------------------------
diff --git a/settings.gradle b/settings.gradle
index 8fd2d6c..0e03868 100644
--- a/settings.gradle
+++ b/settings.gradle
@@ -27,6 +27,8 @@ include 'gemfire-pulse'
 include 'gemfire-assembly'
 include 'gemfire-rebalancer'
 include 'gemfire-lucene'
+include 'gemfire-wan'
+include 'gemfire-cq'
 
 def minimumGradleVersion = '2.3'
 if (GradleVersion.current() < GradleVersion.version(minimumGradleVersion)) {


Mime
View raw message