geode-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mbr...@apache.org
Subject incubator-geode git commit: [GEODE-5] Add Gradle version check and fail if not using minimum Gradle version.
Date Wed, 03 Jun 2015 18:20:57 GMT
Repository: incubator-geode
Updated Branches:
  refs/heads/develop 76d4386a7 -> 75fe2f52c


[GEODE-5] Add Gradle version check and fail if not using minimum Gradle version.

Tested by running build with Gradle 2.2.1, which fails, and with Gradle wrapper, which runs
successfully.
Reviewed by: AMB


Project: http://git-wip-us.apache.org/repos/asf/incubator-geode/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-geode/commit/75fe2f52
Tree: http://git-wip-us.apache.org/repos/asf/incubator-geode/tree/75fe2f52
Diff: http://git-wip-us.apache.org/repos/asf/incubator-geode/diff/75fe2f52

Branch: refs/heads/develop
Commit: 75fe2f52ca0f2e95b1887aedd9d4ca6b5b0bbc22
Parents: 76d4386
Author: mbretl <mbretl@apache.org>
Authored: Wed Jun 3 11:17:50 2015 -0700
Committer: mbretl <mbretl@apache.org>
Committed: Wed Jun 3 11:17:50 2015 -0700

----------------------------------------------------------------------
 settings.gradle | 5 +++++
 1 file changed, 5 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-geode/blob/75fe2f52/settings.gradle
----------------------------------------------------------------------
diff --git a/settings.gradle b/settings.gradle
index d468a79..7f6ed61 100644
--- a/settings.gradle
+++ b/settings.gradle
@@ -8,3 +8,8 @@ include 'gemfire-core'
 include 'gemfire-web'
 include 'gemfire-web-api'
 include 'gemfire-assembly'
+
+def minimumGradleVersion = '2.3'
+if (GradleVersion.current() < GradleVersion.version(minimumGradleVersion)) {
+  throw new GradleException('Running with unsupported Gradle Version. Use Gradle Wrapper
or with Gradle version >= ' + minimumGradleVersion)
+}


Mime
View raw message