gearpump-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kam Kasravi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEARPUMP-84) Propose to define processor types
Date Thu, 21 Apr 2016 16:54:25 GMT

    [ https://issues.apache.org/jira/browse/GEARPUMP-84?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15252192#comment-15252192
] 

Kam Kasravi commented on GEARPUMP-84:
-------------------------------------

Comment from [~stanleyxu2005]

Currently dashboard check the number of inputs and outputs. Subclasses is a good idea.


> Propose to define processor types
> ---------------------------------
>
>                 Key: GEARPUMP-84
>                 URL: https://issues.apache.org/jira/browse/GEARPUMP-84
>             Project: Apache Gearpump
>          Issue Type: Bug
>          Components: Dashboard
>    Affects Versions: 0.8.0
>            Reporter: Kam Kasravi
>             Fix For: 0.8.1
>
>
> Currently we all call them processors, but as you know, processors can be sightly different.
Here are the types I see:
> # Only has outputs, no inputs (data source)
> # Only has inputs, no outputs (data sink)
> # Has both inputs and outputs
> If this terminology makes sense, it will help user to understand the infrastructure of
an application more clearly. And dashboard can use processor types to do:
> # Render DAG nodes in different colors
> # Filter particular processor types for inspection



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message