gearpump-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Huafeng Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GEARPUMP-57) Couldn't load conf/gear.conf
Date Thu, 21 Apr 2016 05:03:25 GMT

    [ https://issues.apache.org/jira/browse/GEARPUMP-57?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15251276#comment-15251276
] 

Huafeng Wang commented on GEARPUMP-57:
--------------------------------------

In function load(source: ClusterConfigSource), it will load gear.conf by default and merge
with application.conf

> Couldn't load conf/gear.conf
> ----------------------------
>
>                 Key: GEARPUMP-57
>                 URL: https://issues.apache.org/jira/browse/GEARPUMP-57
>             Project: Apache Gearpump
>          Issue Type: Bug
>          Components: core, daemon
>    Affects Versions: 0.8.0
>            Reporter: darion yaphet
>            Assignee: darion yaphet
>              Labels: easyfix
>
> I try to make a gearpump cluster and and running gearpump application.
> I found when I start up daemons they are always using application.conf.
> [ClusterConfig$] loading config file application.conf...
> It seems don't specified the config file add 
> -Dgearpump.config.file="${PROG_HOME}/conf/gear.conf"
> in bin/master bin/worker and bin/service will be OK 
> But how to fix building process ?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message