freemarker-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Dekany (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FREEMARKER-92) Add Configuration.VERSION_LATEST
Date Tue, 13 Mar 2018 05:28:00 GMT

    [ https://issues.apache.org/jira/browse/FREEMARKER-92?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16396558#comment-16396558
] 

Daniel Dekany commented on FREEMARKER-92:
-----------------------------------------

There's {{Configuration.getVersion()}} for that, but you should never use that to set the
{{incompatible_improvements}}. New fixes and features are always enabled, except those that
aren't fully backward compatible. If you are using {{Configuration.getVersion()}} as your
{{incompatible_improvements}}, then you application can break when FreeMarker is updated.
The whole point of this mechanism that we can still fix things that can in theory break existing
applications, because using a fix value, like {{Configuration.VERSION_2_3_27}}, protects
existing applications from such fixes.

> Add Configuration.VERSION_LATEST
> --------------------------------
>
>                 Key: FREEMARKER-92
>                 URL: https://issues.apache.org/jira/browse/FREEMARKER-92
>             Project: Apache Freemarker
>          Issue Type: Improvement
>          Components: engine
>    Affects Versions: 2.3.27-incubating
>            Reporter: Yanming Zhou
>            Priority: Major
>             Fix For: 2.3.28-incubating
>
>
> Most people would like use new features, please provide a constant point to latest version.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message