freemarker-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ddek...@apache.org
Subject [1/5] incubator-freemarker git commit: Fixed OSGi Bundle-RequiredExecutionEnvironment; now it requires at least 1.5, and up to 1.8
Date Wed, 15 Mar 2017 20:04:40 GMT
Repository: incubator-freemarker
Updated Branches:
  refs/heads/2.3 a3fb59d69 -> 876fffcfa


Fixed OSGi Bundle-RequiredExecutionEnvironment; now it requires at least 1.5, and up to 1.8


Project: http://git-wip-us.apache.org/repos/asf/incubator-freemarker/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-freemarker/commit/c19efffb
Tree: http://git-wip-us.apache.org/repos/asf/incubator-freemarker/tree/c19efffb
Diff: http://git-wip-us.apache.org/repos/asf/incubator-freemarker/diff/c19efffb

Branch: refs/heads/2.3
Commit: c19efffb00964a970307b5691439f6b5ffa55638
Parents: 7f67e3d
Author: ddekany <ddekany@apache.org>
Authored: Wed Mar 15 20:29:41 2017 +0100
Committer: ddekany <ddekany@apache.org>
Committed: Wed Mar 15 20:31:01 2017 +0100

----------------------------------------------------------------------
 osgi.bnd                  |  4 ++--
 src/manual/en_US/book.xml | 10 ++++++++++
 2 files changed, 12 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-freemarker/blob/c19efffb/osgi.bnd
----------------------------------------------------------------------
diff --git a/osgi.bnd b/osgi.bnd
index 9cc8cd8..08bac25 100644
--- a/osgi.bnd
+++ b/osgi.bnd
@@ -49,10 +49,10 @@ Import-Package: !freemarker.*, *;resolution:="optional"
 # This is needed for "a.class.from.another.Bundle"?new() to work.
 DynamicImport-Package: *
 
-# The required minimum is 1.4, but we utilize 1.5 if available.
+# The required minimum is 1.5, but we utilize versions up to 1.8 if available.
 # See also: http://wiki.eclipse.org/Execution_Environments, "Compiling
 # against more than is required"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5, J2SE-1.4
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8, JavaSE-1.7, JavaSE-1.6, J2SE-1.5
 
 # Non-OSGi meta:
 Main-Class: freemarker.core.CommandLine

http://git-wip-us.apache.org/repos/asf/incubator-freemarker/blob/c19efffb/src/manual/en_US/book.xml
----------------------------------------------------------------------
diff --git a/src/manual/en_US/book.xml b/src/manual/en_US/book.xml
index 69cd696..9cfcf92 100644
--- a/src/manual/en_US/book.xml
+++ b/src/manual/en_US/book.xml
@@ -26941,6 +26941,16 @@ TemplateModel x = env.getVariable("x");  // get variable x</programlisting>
             </listitem>
 
             <listitem>
+              <para>Bug fixed: The OSGi
+              <literal>Bundle-RequiredExecutionEnvironment</literal> entry in
+              <literal>META-INF/MANIFEST.MF</literal> has incorrectly stated
+              that the minimum required version is
+              <literal>J2SE-1.4</literal>, while it's in fact
+              <literal>J2SE-1.5</literal>. Also the highest utilized version
+              was raised to <literal>JavaSE-1.8</literal>.</para>
+            </listitem>
+
+            <listitem>
               <para>Bug fixed: If <link
               linkend="pgui_config_incompatible_improvements_how_to_set">the
               <literal>incompatible_improvements</literal> setting</link>
is


Mime
View raw message