freemarker-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonardo Zorzi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FREEMARKER-46) Empty value
Date Fri, 24 Feb 2017 13:07:44 GMT

    [ https://issues.apache.org/jira/browse/FREEMARKER-46?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15882635#comment-15882635
] 

Leonardo Zorzi commented on FREEMARKER-46:
------------------------------------------

Yes exist, i print the bean before send to Template .process and all field have correct value.

> Empty value
> -----------
>
>                 Key: FREEMARKER-46
>                 URL: https://issues.apache.org/jira/browse/FREEMARKER-46
>             Project: Apache Freemarker
>          Issue Type: Bug
>          Components: engine
>    Affects Versions: 2.3.23
>         Environment: Java 1.8, Tomcat 8.0.15
>            Reporter: Leonardo Zorzi
>            Priority: Critical
>
> Sorry for my bud english.
> I've installed freemarker in develop enviroment (java 1.8, tomcat 8.0.15, Windows 7)
and all is ok. When put software in production (jdk 1.8, tomcat 8.0.31, Windows Server 2008)
don't work.
> The template:
> <#list titoli as titolo>
> 			<tr>
> 				<td>${(titolo.argomento1)!"default text"}</td>
> 				<td>${(titolo.argomento2)!"default text"}</td>
> 				<td>${(titolo.argomento3)!"default text"}</td>
> 				<td>${(titolo.nome)!"default text"}</td>
> 				<td>${(titolo.titolo)!"default text"}</td>
> 				<td>${(titolo.tipo)!"default text"}</td>
> 			</tr>
> 			</#list>
> In develop is ok, in production all field are "default text" and the number of row is
the same. (the origin of data is the same, and the beans are full with correct data!)
> What is the problem!?
> Thank you!



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message