some more verbose output from the one remaining error

BUILD FAILED
/home/lewis/ASF/forrest/main/targets/site.xml:224: Error building site.
       
There appears to be a problem with your site build.

Read the output above:
* Cocoon will report the status of each document:
    - in column 1: *=okay X=brokenLink ^=pageSkipped (see FAQ).
* Even if only one link is broken, you will still get "failed".
* Your site would still be generated, but some pages would be broken.
  - See /home/lewis/ASF/site/forrest/build/site/broken-links.xml
    at org.apache.tools.ant.taskdefs.Exit.execute(Exit.java:142)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
    at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
    at net.sf.antcontrib.logic.IfTask.execute(IfTask.java:197)
    at sun.reflect.GeneratedMethodAccessor22.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.TaskAdapter.execute(TaskAdapter.java:154)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
    at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:357)
    at org.apache.tools.ant.Target.performTasks(Target.java:385)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
    at org.apache.tools.ant.Main.runBuild(Main.java:758)
    at org.apache.tools.ant.Main.startAnt(Main.java:217)
    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

thank you to anyone who is familiar with these stack traces.

On Sat, Sep 17, 2011 at 3:09 PM, lewis john mcgibbney <lewis.mcgibbney@gmail.com> wrote:
Well I've sorted the first of the complaints regarding <link message="No pipeline matched request: error:ext:wiki">error:ext:wiki</link>, this was a case of methdically going through the full site after running the Jetty webapp and checking all hyper-links.

The first problem still persists, the folowing log output from  rwads/build/webapp/WEB-INF/logs/locationmap.log reads
WARN    (2011-09-17) 14:58.56:690   [core.modules.mapper.lm] (/about.html): Failed to mount locationmap at: cocoon://locationmap-project.xml

with the more verbose core.log showing
...
WARN    (2011-09-17) 15:06.37:329   [access] (/images/feather-small.gif) 16842840@qtp-78236-0/CocoonServlet: Error during resolving of the input stream
    at <map:read> - file:///home/lewis/ASF/forrest/main/webapp/resources.xmap:215:81
    at <map:mount> - file:///home/lewis/ASF/forrest/main/webapp/sitemap.xmap:603:76
WARN    (2011-09-17) 15:06.37:634   [access] (/images/feather-small.gif) 5122060@qtp-78236-3/CocoonServlet: Error during resolving of the input stream
    at <map:read> - file:///home/lewis/ASF/forrest/main/webapp/resources.xmap:215:81
    at <map:mount> - file:///home/lewis/ASF/forrest/main/webapp/sitemap.xmap:603:76
WARN    (2011-09-17) 15:06.37:696   [access] (/skin/images/header_white_line.gif) 17890856@qtp-78236-7/CocoonServlet: Error during resolving of the input stream
    at <map:read> - file:///home/lewis/ASF/forrest/main/webapp/resources.xmap:194:78
    at <map:mount> - file:///home/lewis/ASF/forrest/main/webapp/sitemap.xmap:603:76
WARN    (2011-09-17) 15:06.37:700   [access] (/skin/images/chapter_open.gif) 22725577@qtp-78236-5/CocoonServlet: Error during resolving of the input stream
    at <map:read> - file:///home/lewis/ASF/forrest/main/webapp/resources.xmap:194:78
    at <map:mount> - file:///home/lewis/ASF/forrest/main/webapp/sitemap.xmap:603:76
WARN    (2011-09-17) 15:06.45:785   [access] (/inc/specials/cream/hi/news/igooglejs/ping.js) 8509315@qtp-78236-12/CocoonServlet: Error during resolving of the input stream
    at <map:read> - file:///home/lewis/ASF/forrest/main/webapp/resources.xmap:140:84
    at <map:mount> - file:///home/lewis/ASF/forrest/main/webapp/sitemap.xmap:597:76
WARN    (2011-09-17) 15:07.27:536   [access] (/talkgadget/channel/test) 8509315@qtp-78236-12/CocoonServlet: No pipeline matched request: talkgadget/channel/test
WARN    (2011-09-17) 15:07.27:553   [access] (/images/cleardot.gif) 8509315@qtp-78236-12/CocoonServlet: Error during resolving of the input stream
    at <map:read> - file:///home/lewis/ASF/forrest/main/webapp/resources.xmap:215:81
    at <map:mount> - file:///home/lewis/ASF/forrest/main/webapp/sitemap.xmap:603:76

I suspect that I was right when I thought various images were causing a problem. Any problems with this debug info? I am unfamiliar with the errors.

Thanks for any help.


On Fri, Sep 16, 2011 at 6:42 PM, lewis john mcgibbney <lewis.mcgibbney@gmail.com> wrote:
Hi guys,

A mistake by myself, it is apache-forrest-0.10-dev I am using to build the site sorry.

An update... the 1st problem seems to be with the apache feather logo which is defined in skinconf.xml as follows
  <!-- group logo -->
  <group-name>Apache</group-name>
  <group-description>Apache Software Foundation</group-description>
  <group-url>http://www.apache.org/</group-url>
  <group-logo>http://www.apache.org/images/feather-small.gif</group-logo>

When I view my changes in the Jetty webapp the feather is not present on the index.html page, therefore I suspect that this is why this issue is occurring. Any ideas to sort this one out please?

I am still stumped as to the second error as the logging doesn't highlight where is is coming.

Thanks for pointers if any.

Lewis

[1] http://www.apache.org/images/feather-small.gif

On Thu, Sep 15, 2011 at 10:08 PM, lewis john mcgibbney <lewis.mcgibbney@gmail.com> wrote:
Hi list,

Using the most recent stable forrest release I made some changes to the Apache Nutch site (haven't committed them yet due to problems) but building our site code with 'forrest' fails with the following material in broken-links.xml

<broken-links>
  <link message="The current document is unable to create an element of the requested type (namespace: http://www.w3.org/2000/svg, name: html).">index.pdf</link>
  <link message="No pipeline matched request: error:ext:wiki">error:ext:wiki</link>
</broken-links>

Is there any way to get more verbose messages? I've had a look through the files I edited and new ones I created and can seem to figure this one out myself.

Thank you very much for any suggestions.
--
Lewis




--
Lewis




--
Lewis




--
Lewis