forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szabo, Patrick \(LNG-VIE\)" <patrick.sz...@lexisnexis.at>
Subject AW: AW: AW: moving to different hardware
Date Fri, 17 Dec 2010 07:26:57 GMT
Okay no JAVA_HOME warning anymore, i removed the \bin.
Now jetty seems to start but there are some Java exceptions:

08:24:07.805 EVENT  Checking Resource aliases
08:24:08.696 EVENT  Starting Jetty/4.2.19
08:24:08.774 EVENT  Started WebApplicationContext[/,Apache Forrest]
08:24:09.462 EVENT  Started SocketListener on 0.0.0.0:8888
08:24:09.462 WARN!!
org.mortbay.util.MultiException[java.lang.NullPointerException]
        at org.mortbay.http.HttpServer.start(HttpServer.java:640)
        at org.mortbay.jetty.Server.main(Server.java:429)
[0]=java.lang.NullPointerException
        at org.apache.cocoon.servlet.multipart.RequestFactory.<init>(RequestFact
ory.java:61)
        at org.apache.cocoon.servlet.CocoonServlet.init(CocoonServlet.java:456)
        at org.mortbay.jetty.servlet.ServletHolder.start(ServletHolder.java:220)

        at org.mortbay.jetty.servlet.ServletHandler.initializeServlets(ServletHa
ndler.java:445)
        at org.mortbay.jetty.servlet.WebApplicationHandler.initializeServlets(We
bApplicationHandler.java:150)
        at org.mortbay.jetty.servlet.WebApplicationContext.start(WebApplicationC
ontext.java:458)
        at org.mortbay.http.HttpServer.start(HttpServer.java:663)
        at org.mortbay.jetty.Server.main(Server.java:429)


Does anyone know what this means ?!

Thanks in advance and kind regards 


. . . . . . . . . . . . . . . . . . . . . . . . . .
Patrick Szabo
 XSLT-Entwickler 
LexisNexis
Marxergasse 25, 1030 Wien

mailto:patrick.szabo@lexisnexis.at
Tel.: +43 (1) 534 52 - 1573 
Fax: +43 (1) 534 52 - 146 


-----Ursprüngliche Nachricht-----

Von: Gav... [mailto:gavin@16degrees.com.au] 
Gesendet: Donnerstag, 16. Dezember 2010 21:44
An: user@forrest.apache.org
Betreff: RE: AW: AW: moving to different hardware



> -----Original Message-----
> From: Szabo, Patrick (LNG-VIE) [mailto:patrick.szabo@lexisnexis.at]
> Sent: Friday, 17 December 2010 12:46 AM
> To: user@forrest.apache.org
> Subject: AW: AW: AW: moving to different hardware
> 
> Okay, it already looks a little bit better - i can do 'forrest run now'
> 
> If i do so he sill warns me that JAVA_HOME isn't set and the build
> fails with:
> 
> Error occurred during initialization of VM
> Could not reserve enough space for object heap
> Could not create the Java virtual machine.
> 
> BUILD FAILED
> C:\forrest\apache-forrest\main\forrest.build.xml:434: Java returned: 1
> 
> echo %PATH%:
> C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\syst
> em32\WindowsPowerShell\v1.0;C:\forrest\apache-
> forrest\bin;C:\Programme\Java\jdk1.6.0_03\bin
> 
> any suggestions ?!
> 

I would remove \bin from the JAVA_HOME path.

then, any changes you make you need to close any open 'cmd' windows and open
a new one, so do that and test by 

java --version

Gav...

> 
> . . . . . . . . . . . . . . . . . . . . . . . . . .
> Patrick Szabo
>  XSLT-Entwickler
> LexisNexis
> Marxergasse 25, 1030 Wien
> 
> mailto:patrick.szabo@lexisnexis.at
> Tel.: +43 (1) 534 52 - 1573
> Fax: +43 (1) 534 52 - 146
> 
> 
> -----Ursprüngliche Nachricht-----
> 
> Von: Gav... [mailto:gavin@16degrees.com.au]
> Gesendet: Donnerstag, 16. Dezember 2010 13:51
> An: user@forrest.apache.org
> Betreff: RE: AW: AW: moving to different hardware
> 
> 
> 
> > -----Original Message-----
> > From: Michael Conneen [mailto:mconneen@infointegrators.com]
> > Sent: Thursday, 16 December 2010 10:35 PM
> > To: user@forrest.apache.org
> > Subject: Re: AW: AW: moving to different hardware
> >
> > On Dec 16, 2010, at 6:19, "Szabo, Patrick \(LNG-VIE\)"
> > <patrick.szabo@lexisnexis.at> wrote:
> >
> > >
> > > Thanks you for your really fast response.
> > > I've also noticed that it says that JAVA_HOME is not set but it is
> :-
> > (
> > >
> > > Here is what those echos are giving me.
> > >
> > > Echo %JAVA_HOME%: C:\Programme\Java\jdk1.6.0_03\bin
> > > Echo %FORREST_HOME%: C:\forrest\apache-forrest
> > > Echo %PATH%:
> >
> C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\syst
> > em32\WindowsPowerShell\v1.0;%FORREST_HOME%\bin
> > >
> > I do not see Java on the path... That is why you get the error java
> not
> > found.  Put java on the path.
> >
> > Your %FORREST_HOME% did not expand .. I am more of a Mac person, but
> I
> > would have expected to see C:\forrest\apache-forrest instead.  Try
> hard
> > coding that..
> >
> 
> Right, was just going to post the same. That should cure it.
> 
> Gav...
> 
> > > Seems right to me...
> > >
> > > Kind regards
> > >
> > >
> > >>
> > > . . . . . . . . . . . . . . . . . . . . . . . . . .
> > > Patrick Szabo
> > > XSLT-Entwickler
> > > LexisNexis
> > > Marxergasse 25, 1030 Wien
> > >
> > > mailto:patrick.szabo@lexisnexis.at
> > > Tel.: +43 (1) 534 52 - 1573
> > > Fax: +43 (1) 534 52 - 146
> > >
> > >
> > > -----Original Message-----
> > >
> > >> From: Szabo, Patrick (LNG-VIE)
> [mailto:patrick.szabo@lexisnexis.at]
> > >> Sent: Thursday, 16 December 2010 10:06 PM
> > >> To: user@forrest.apache.org
> > >> Subject: AW: AW: moving to different hardware
> > >>
> > >> Hi,
> > >>
> > >> Today was the day.
> > >> We copied all the files (install folder and project folder) und
> set
> > the
> > >> variables.
> > >> Unfortunately it's not working.
> > >>
> > >> We did the following:
> > >>
> > >> We copied apache-forrest and workflow-dok (that's our project) to
> > >> C:\forrest\.
> > >> We set the Variables to:
> > >>
> > >> FORREST_HOME = C:\forrest\apache-forrest\
> > >> Path = ...;%FORREST_HOME%\bin
> > >>
> > >> We did a restart and the variables are set properly.
> > >> If we enter 'forrest run' it says that it does not recognize
> forrest
> > as
> > >> a command.
> > >
> > > Does not sound like the variables are set properly.
> > >
> > > Please open a cmd window and paste the output of
> > >
> > > echo %FORREST_HOME%
> > >
> > > echo %PATH%
> > >
> > >
> > >>
> > >> We've also tried to run the forrest.bat directly with 'forrest.bat
> > >> run'.
> > >> It starts running but the build fails with an error that it can't
> > find
> > >> a documentation folder in C:\forrest\apache-forrest\. That's weird
> > >> because our project-folder is C:\forrest\workflow-dok anyway.
> > >
> > > Because you need to run the command from the project directory
> which
> > > you can't do without the 'forrest' command working.
> > >
> > > Gav...
> > >
> > >>
> > >> What are we doing wrong ?!
> > >>
> > >> PS: I can't take a look at the configuration of our old server
> since
> > it
> > >> is not located in the same building (or country) and i have no
> > remote-
> > >> acced.
> > >>
> > >> Thanks in advance
> > >>
> > >> Kind regards
> > >>
> > >>
> > >> . . . . . . . . . . . . . . . . . . . . . . . . . .
> > >> Patrick Szabo
> > >> XSLT-Entwickler
> > >> LexisNexis
> > >> Marxergasse 25, 1030 Wien
> > >>
> > >> mailto:patrick.szabo@lexisnexis.at
> > >> Tel.: +43 (1) 534 52 - 1573
> > >> Fax: +43 (1) 534 52 - 146
> > >>
> > >>
> > >> -----Ursprüngliche Nachricht-----
> > >>
> > >> Von: Michael Conneen [mailto:mconneen@infointegrators.com]
> > >> Gesendet: Mittwoch, 15. Dezember 2010 13:35
> > >> An: user@forrest.apache.org
> > >> Betreff: Re: AW: moving to different hardware
> > >>
> > >> Most set FORREST_HOME to the apache Forrest root and then include
> > >> FORREST_HOME/bin on the path.  As such, it would then be system
> > wide.
> > >>
> > >> Most of this is RTFM at http://forrest.apache.org/docs_0_90/your-
> > >> project.html#Setting+up+the+Environment.
> > >>
> > >> Best of luck and enjoy Forrest!
> > >>
> > >>
> > >>
> > >> On Dec 15, 2010, at 0:54, "Szabo, Patrick \(LNG-VIE\)"
> > >> <patrick.szabo@lexisnexis.at> wrote:
> > >>
> > >>> Thank you for all of your answers !
> > >>>
> > >>> The move is sheduled for Thursday so i might be able to tell you
> if
> > >> it workes then.
> > >>> Anothers thing i was wondering in which directory do i have to be
> > to
> > >> run
> > >>> 'forrest commands' or is that an "systemwide" command once i set
> > the
> > >> variables ?!
> > >>>
> > >>> I did not maintain the server so i've never done that before.
> > >>>
> > >>>
> > >>>
> > >>>
> > >>> . . . . . . . . . . . . . . . . . . . . . . . . . .
> > >>> Patrick Szabo
> > >>> XSLT-Entwickler
> > >>> LexisNexis
> > >>> Marxergasse 25, 1030 Wien
> > >>>
> > >>> mailto:patrick.szabo@lexisnexis.at
> > >>> Tel.: +43 (1) 534 52 - 1573
> > >>> Fax: +43 (1) 534 52 - 146
> > >>>
> > >>>
> > >>> -----Ursprüngliche Nachricht-----
> > >>>
> > >>> Von: David Crossley [mailto:crossley@apache.org]
> > >>> Gesendet: Mittwoch, 15. Dezember 2010 02:10
> > >>> An: user@forrest.apache.org
> > >>> Betreff: Re: moving to different hardware
> > >>>
> > >>> Tim Williams wrote:
> > >>>> Szabo, Patrick wrote:
> > >>>>>
> > >>>>> I have to move our forrest installation to a different
> hardware.
> > >> Since i
> > >>>>> didn't install and configure it myself i'm wondering how to
do
> > >> that.
> > >>>>>
> > >>>>> Is it possible to just copy the directories, set the Enviroment
> > >> Variables?!
> > >>>>>
> > >>>>> Would that work ?! If not...why not ?!
> > >>>>
> > >>>> Hi Patrick,
> > >>>> Assuming you have Java installed on the new machine, simply
> > copying
> > >>>> everything (Forrest + Your Project) should work just fine. Good
> > >> luck!
> > >>>
> > >>> Patrick, the configuration should not have any system-specific
> > >>> settings, so it should be okay.
> > >>>
> > >>> I was wondering about the "cache". I expect that it too should
> > >>> be portable. If you do see issues then do 'forrest clean'
> > >>> in each of your projects.
> > >>>
> > >>> -David
> > >>>
> > >>>
> > >>
> > >
> > >
> > >
> > >
> > >
> 
> 
> 






Mime
View raw message