forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryce Alcock <ba.li...@brycealcock.com>
Subject Failure Building Business Site after initial Seed.
Date Fri, 01 Oct 2010 03:25:35 GMT
Each time I use Forrest to seed a new site,
The site initial fails to build with the following Errors:

-----------------------------------------------------------------------------
.....
validate-skinconf:
/home/bryce/repos/brycealcock/rohl/src/documentation/skinconf.xml:380:17:
Element type "url-prefix" must be declared.
/home/bryce/repos/brycealcock/rohl/src/documentation/skinconf.xml:393:18:
Element type "disable-toc" must be declared.
/home/bryce/repos/brycealcock/rohl/src/documentation/skinconf.xml:394:9:
The content of element type "pdf" must match
"(page,page-numbering-format?,margins?,show-external-urls?,disable-copyright-footer?)".

BUILD FAILED
.....
-----------------------------------------------------------------------------


Steps to Repoduce:
I AM USING THE LATEST CODE FROM SVN, but I tried it with code from
several months back as well.
FORREST VERSION:
Apache Forrest 0.9-dev

1.  cd to a new clean directory.
2.  forrest seed-business
3.  Fill in all the questions or choose the defaults (It doesn't seem to matter)
4.  forrest site
The error occurs on step 4.

Work Around:
Go hand edit the skinconf.xml file to remove the tags that fail validation.
(I am not sure if those elements are expected to be somewhere in a
style sheet...)



+----------------------------------------------------+
| Contact Info
+----------------------------------------------------+
| linkedIn: http://www.linkedin.com/in/brycealcock
| Website:  http://brycealcock.com
| Blog: http://quantprinciple.blogspot.com
| twitter: qboiler
+----------------------------------------------------+

Mime
View raw message