forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ionut Scutaru <ionut.scut...@gmail.com>
Subject Re: problem with incorrect tab selection
Date Fri, 12 Feb 2010 13:22:34 GMT
Thanks, David ! That was it !


On Fri, Feb 12, 2010 at 3:05 PM, David Crossley <crossley@apache.org> wrote:

> Ionut Scutaru wrote:
> > The issue is that, for some links, the currently selected tab is moved
> back
> > to the first one but the contents of the page remains correct.
> Practically,
> > the Design page is shown correctly, but not under the "Architecture" tab,
> as
> > it should, but under the "Release Notes" tab.
> >
> > I tried to figure out what's different for those links compared with the
> > ones that work correctly and I noticed something:
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> > <site xmlns="http://apache.org/forrest/linkmap/1.0" label="Proj" href=""
> > tab="releasenotes">
> >
> >     <releaseInformation label="Release Information"
> > href="project/release_documentation/" tab="releasenotes">
> >         <releaseOverview label="Welcome" href="index.html"/>
> >     </releaseInformation>
> >
> >     <architecture label="Overview" href="project/architecture/"
> > tab="architecture">
> >         <arcOverview label="Architecture Overview" href="index.html"/>
> >         <arcDesign label="Design Patters" href="site:designPatterns"/>
> >     </architecture>
> >
> >     <designPatterns href="general/documentation/designPatterns.html"/>
> >
> > </site>
> >
> > The structure of the folders is as follows:
> >     <parentFolder>
> >         project\release_documentation\
> >         project\architecture\
> >         general\documentation\
> >
> > When I click on the "Design Patterns" link I'm taken to the right page,
> but
> > the Architecture tab do not remain selected, but instead the "Release
> Notes"
> > tab gets active.
>
> I reckon that is because the default "tab" attribute
> of the "site" element of your site.xml is "releasenotes".
>
> The "designPatterns" element needs a "tab=architecture"
> attribute, rather than the default.
>
> -David
>

Mime
View raw message