forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: problem with incorrect tab selection
Date Thu, 11 Feb 2010 14:28:00 GMT
On Thu, Feb 11, 2010 at 8:36 AM, Ionut Scutaru <ionut.scutaru@gmail.com> wrote:
> Hi,
> Our project has it's documentation site generated with Apache Forrest
> (v0.6). The site is up and running and in general everything is working
> fine. However.. there is a slight problem that was noticed and I don't know
> if this is a bug or something that we configured wrong in the xml files.
>
> The issue is that, for some links, the currently selected tab is moved back
> to the first one but the contents of the page remains correct. Practically,
> the Design page is shown correctly, but not under the "Architecture" tab, as
> it should, but under the "Release Notes" tab.
>
> I tried to figure out what's different for those links compared with the
> ones that work correctly and I noticed something:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <site xmlns="http://apache.org/forrest/linkmap/1.0" label="Proj" href=""
> tab="releasenotes">
>
>     <releaseInformation label="Release Information"
> href="project/release_documentation/" tab="releasenotes">
>         <releaseOverview label="Welcome" href="index.html"/>
>     </releaseInformation>
>
>     <architecture label="Overview" href="project/architecture/"
> tab="architecture">
>         <arcOverview label="Architecture Overview" href="index.html"/>
>         <arcDesign label="Design Patters" href="site:designPatterns"/>
>     </architecture>
>
>     <designPatterns href="general/documentation/designPatterns.html"/>
>
> </site>
>
> The structure of the folders is as follows:
>     <parentFolder>
>         project\release_documentation\
>         project\architecture\
>         general\documentation\
>
> When I click on the "Design Patterns" link I'm taken to the right page, but
> the Architecture tab do not remain selected, but instead the "Release Notes"
> tab gets active.
>
> It seems to me there is a problem with the indirect linking, but I can't
> pinpoint it..

Can you share your tabs definition?  I seem to remember some problems
with loosing context in 0.6 - have you had a chance to search JIRA for
old issues?

--tim

Mime
View raw message