forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Glavassevich <>
Subject Re: Unable to build xml-commons website with Forrest 0.7
Date Thu, 17 Dec 2009 03:20:20 GMT


David Crossley <> wrote:

> Michael Glavassevich wrote:
> >
> > It's been a long time since I've tried building the XML Commons website
> > I'm not sure how to get past this. I tried to build the site with a
> > install of Forrest 0.7 (recommended in the build instructions on the
> > Commons website [1]) but had no luck. Hoping someone who uses Forrest
> > often would have an idea what's going on here.
> I cannot help with those errors.
> One workaround to get the release published would be to disable
> the "PDF" production:
> In src/documentation/skinconf.xml disable-pdf-link = true
> In project.required.plugins remove pdf plugin
> -David

Thanks, that worked well enough to get the pages I wanted generated, but it
still didn't complete cleanly:

"Logging Error: Writing event to closed stream.
Total time: 0 minutes 20 seconds,  Site size: 230,302 Site pages: 38

D:\apache-forrest-0.7\main\targets\site.xml:41: Java returned: 1"

I'm not going to worry about that though.



Thomas Witteriede <> wrote:

> Hi,
> do you have any special requirements so that you are using Forrest 0.7?
> The current stable release (to my knowledge) is 0.8, if it is not 0.9
> already. Have a go with 0.8 and if you are using Windows, it might be
> worth a try to use an older Java version (1.5_xx) instead of a current?
> one (works for me).
> The web page you quoted seems ancient, go to
> for a?
> more current doc on installing and using Forrest.
> Best regards
> Thomas

I'm just trying to build an existing site (that I didn't develop aside from
adding a little bit of content). I'm not sure what requirements it has, but
I tried 0.8 first and it also didn't work. I vaguely remember the last time
around having to pick up a dev version of 0.7 and applying at least one
patch to it from SVN. Given that I couldn't get it to build cleanly with
0.7 or 0.8 I have suspicion that the XML Commons site is locked into some
unreleased in-development version of Forrest (0.7?) and won't build
normally without that. At least I got the pages I needed after turning PDF
generation off.


Michael Glavassevich
XML Parser Development
IBM Toronto Lab
View raw message