forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Unable to build xml-commons website with Forrest 0.7
Date Thu, 17 Dec 2009 06:26:51 GMT
Michael Glavassevich wrote:
> Tim Williams wrote:
> >
> > Without all the initial output from the build it's tough to say, but I
> > wonder if you've run into a plugin version problem[1].  Would it be
> > much trouble to upgrade to 0.8?  I have no clue whether this would
> > work or not with a 0.7 instance, but if you can't just upgrade, you
> > might try adding a 0.1 extension to the pdf plugin - though, honestly,
> > I haven't seen that error before in an instance like that.
> 
> 0.8 (which I tried first) didn't work for me either, so gave 0.7 a spin
> because it was listed in the build instructions for the site. David's
> suggestion to turn off PDF generation did the trick.
> 
> > --tim
> >
> > [1] - http://forrest.apache.org/docs_0_80/faq.html#older-plugins

Yes, i wondered if this might be the issue.

The PDF plugin was upgraded recently and re-deployed.
However it was not deployed properly, by incrementing its
version numbers. So the currently deployed plugin cannot
be used with 0.7 or 0.8 versions of Forrest.

I made the following change to forrest.properties to use an
old version of the PDF plugin, and committed it to xml-commons today.
It now works for me with Forrest-0.7

--------------
-project.required.plugins=org.apache.forrest.plugin.output.pdf,org.apache.forrest.plugin.input.projectInfo-0.1
+project.required.plugins=org.apache.forrest.plugin.output.pdf-0.1,org.apache.forrest.plugin.input.projectInfo-0.1
--------------

We will take that up on our dev list.

Sorry for the inconvenience.

-David

Mime
View raw message