forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Unable to build xml-commons website with Forrest 0.7
Date Thu, 17 Dec 2009 06:19:30 GMT
Michael Glavassevich wrote:
> David Crossley wrote:
> >
> > One workaround to get the release published would be to disable
> > the "PDF" production:
> > In src/documentation/skinconf.xml disable-pdf-link = true
> > In forrest.properties project.required.plugins remove pdf plugin
> 
> Thanks, that worked well enough to get the pages I wanted generated, but it
> still didn't complete cleanly:
> 
> "Logging Error: Writing event to closed stream.
> Total time: 0 minutes 20 seconds,  Site size: 230,302 Site pages: 38
> 
> BUILD FAILED
> D:\apache-forrest-0.7\main\targets\site.xml:41: Java returned: 1"
> 
> I'm not going to worry about that though.

Yes it is a strange message with forrest-0.7 that is ignorable.

> I'm just trying to build an existing site (that I didn't develop aside from
> adding a little bit of content). I'm not sure what requirements it has, but
> I tried 0.8 first and it also didn't work. I vaguely remember the last time
> around having to pick up a dev version of 0.7 and applying at least one
> patch to it from SVN. Given that I couldn't get it to build cleanly with
> 0.7 or 0.8 I have suspicion that the XML Commons site is locked into some
> unreleased in-development version of Forrest (0.7?) and won't build
> normally without that. At least I got the pages I needed after turning PDF
> generation off.

That is not what i recall.

At the time, 0.7 was the current release of Forrest.
The XML Commons project has not updated to Forrest-0.8 yet.
So the Commons documentation still says that 0.7 is the
agreed version in use.

The reason is as Tim described in another message today.
See my later reply there.

-David

Mime
View raw message