forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dr. Bhatia Praveen" <praveen.bha...@sumpurn.com>
Subject Re: Japanese PDF rendering
Date Sun, 19 Apr 2009 03:45:32 GMT
Hello Heather,
   I have made Japanese characters work in 0.8. I had similar problems as 
yours earlier but few months of work got it right.
   In short, the problem is with the Japanese fonts and the new version of 
Forrest.

  Please note that the instructions that you are following in the link are 
right for pre 0.8 version of Forrest but need some changes for 0.8 version.

   The steps that I remember having used are:
1) Choose a Japanese font, say MS Gothic
2) Convert this to .xml metrics, say gothic.xml (instructions are available 
on the site that you have given)
3) In userconfig.xml direct the pdf generator to refer to this gothic.xml 
for Japanese. (TILL HERE SAME STEPS as yours)
4) (CHANGE HERE for 0.8 version) INSTEAD OF SITEMAP put the reference to 
userconfig.xml in the output.xmap as given below:
forrest\apache-forrest-0.8\plugins\org.apache.forrest.plugin.output.pdf/output.xmap

That should get the right fonts to work for you in the pdf file.

best wishes
Praveen

----- Original Message ----- 
From: "Heather Phipps" <hmphipps@gmail.com>
To: <user@forrest.apache.org>
Sent: Sunday, April 19, 2009 9:24 AM
Subject: Japanese PDF rendering


> Hello,
>
> I am having trouble getting a Japanese XML document to display
> properly in PDF form.
>
> I set up the basic site that comes with Apache Forrest.  The only
> changes I made were to add the docbook dtd (v4.4) and the docbook
> stylesheets from sourceforge and change the sitemap accordingly.  I
> then added a docbook file with Japanese text to the samples directory.
> I followed the directions here:
> http://www.terra-intl.com/agel/2005/11/forrest_japanese.html.  Then
> when I run Forrest, the html document is generated correctly, but the
> PDF still has ####### instead of Japanese text.  (New English XML
> files display fine both in HTML and PDF format.)
>
> Any ideas as to where I'm going wrong, or how I might start to debug?
>
> Other info:
> Mac OS 10.5.6
> Java 1.5.0_16
> Forrest 0.8
>
> -Heather
>


--------------------------------------------------------------------------------



No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.0.238 / Virus Database: 270.11.59/2063 - Release Date: 04/16/09 
16:38:00


Mime
View raw message