forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klortho <Voldr...@gmail.com>
Subject Not compatible with Java 1.6?
Date Mon, 02 Mar 2009 04:47:44 GMT

Hi, I'm new to Forrest -- is it still being actively maintained?
I just tried downloading version 1.8, according to the tutorial here: 
http://forrest.apache.org/docs_0_90/your-project.html
I got through "forrest seed" and "forrest run" fine, but then, when I tried
to generate a static site with "forrest", I got a bunch of errors of this
form:

  ....
  validate-sitemap:
 
C:\bin\apache-forrest-0.8\main\webapp\resources\schema\relaxng\sitemap-v06.rng:72:31:
    error: datatype library "http://www.w3.org/2001/XMLSchema-datatypes" not
    recognized
 
C:\bin\apache-forrest-0.8\main\webapp\resources\schema\relaxng\sitemap-v06.rng:81:31:
    error: datatype library "http://www.w3.org/2001/XMLSchema-datatypes" not
    recognized
  ....

I then found this message: 
http://www.mail-archive.com/user@forrest.apache.org/msg02833.html that seems
to indicate that Forrest isn't compatible with Java 1.6.

Is that right?  I'd really rather not install an older version of the JDK
just to play around with Forrest.  If that's really the cause of my problem,
I don't understand why more people don't encounter it -- why there weren't a
lot more hits when I searched for the error message.  

Also, what about updating that tutorial page to reflect that?  Maybe Forrest
0.9 doesn't have this problem, but that tutorial page, despite being under
the 0.9 documentation, links to a download page that has no links for
version 0.9 -- only 0.8.  At least a note in the tutorial page about this
issue would have saved me a lot of time.

-- 
View this message in context: http://www.nabble.com/Not-compatible-with-Java-1.6--tp22282043p22282043.html
Sent from the Apache Forrest - Users mailing list archive at Nabble.com.


Mime
View raw message