forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ARobert <tibeto...@gmail.com>
Subject Re: PDF not working correctly in deployed WAR file on Tomcat
Date Thu, 04 Dec 2008 08:43:03 GMT

Ok thanks for your answer ... 

I will continue to talk about that on the JIRA issue i opened 
https://issues.apache.org/jira/browse/FOR-1133

Thanks


rgardler wrote:
> 
> 
> On 3 Dec 2008, at 08:20, ARobert wrote:
> 
>>
>> Why should I test 0.9-dev ... I'm talking about the official current  
>> release
>> !
>> I don't want to test the 0.9-dev version, since it's a dev  
>> version ....
>>
>> I need forrest in a company context, and I can't install a dev  
>> version.
>>
>> IMYO forrest 0.8 should be fully fonctional with current products  
>> releases
>> (Tomcat, etc.), and this issue should be in JIRA
> 
> 0.8 was tested against tomcat before it was released. It worked at  
> that time.
> 
> It might be that recent changes in components used in the plugin  
> pipeline have since broken the release. Whilst it would be great if  
> this never happened we cannot possibly track every single project and  
> system configuration. Demanding that "0.8 should be fully functional  
> with current product releases" helps nobody..
> 
> Helping us solve the problem will result an increased attention from  
> the developers. We are not here to provide free support for your  
> company we are here because we have specific needs and since none of  
> us are hitting the problem you describe you can be pretty sure our  
> needs are not aligned with your own (although some people here will  
> happily focus solely on your problem if you want to pay them).
> 
> If you would be so kind as to raise the JIRA issue as you suggest, add  
> as much detail as you can from your own experiences and the  
> discussions earlier in this thread, and also attach to it information  
> about whether you see the same behaviour in 0.9-dev it would be very  
> helpful.
> 
> We are not saying that you should run 0.9-dev (although many people  
> do), we are asking you to help narrow down whether this is an issue  
> that affects 0.8 on your system configuration alone, or whether it  
> still remains in 0.9. The more you help us the more we can help you,  
> but please don't expect us to fix your problems for you, this is open  
> source not free labour.
> 
> Ross
> 
> 
>>
>>
>> I will add it, as soon as possible
>>
>> Thanks
>>
>> David Crossley wrote:
>>>
>>> ARobert wrote:
>>>>
>>>> Hi thanks for your answer !
>>>>
>>>> Yes I tried verything !
>>>
>>> So you are saying that you have tried 0.9-dev
>>> and it is broken too.
>>>
>>> I will not be commenting anymore on the user list
>>> about this issue.
>>>
>>> -David
>>>
>>>> What's more I think every one can see this error quite easily,  
>>>> since you
>>>> only need to do that
>>>> On any OS, on any browser
>>>> 1/ Download apache-forrest-0.8 (Actual release)
>>>> 2/ Downlaod apache-tomcat-6-0.18 (Actual release)
>>>> 3/ Use java 1.6 (Actual release)
>>>> 4/ forrest seed (To create sample forrest site)
>>>> 5/ forrest war (to create WAR sample forrest site)
>>>> 6/ put the .war in the tomcat webapps folder
>>>> 7/ Launch sample forrest application from tomcat
>>>> 8/ Go to any page with any image of this war sample forrest site
>>>> 9/ Try to see it in PDF version
>>>> 10/ See that you don't have image displayed
>>>>
>>>> That take about 10 minutes (After having download Tomcat, apache  
>>>> and java
>>>> 1.6)
>>>>
>>>> David Crossley wrote:
>>>>>
>>>>> ARobert wrote:
>>>>>>
>>>>>> Hi guys !
>>>>>>
>>>>>> Did someone take a look on this issue ? Are you reproducing ?
>>>>>
>>>>> There has been work done on the PDF plugin. However, i think
>>>>> that you would need to be using the 0.9-dev trunk to take
>>>>> advantage.
>>>>>
>>>>> Have you done all the things suggested earlier in this thread?
>>>>> Do you see the same problems with the "forrest seed" sample site?
>>>>>
>>>>> Anyway, if it still persists after trying the 0.9-dev
>>>>> then i suggest raising the issue on the "dev" mail list.
>>>>>
>>>>> -David
>>>
>>>
>>
>> -- 
>> View this message in context:
>> http://www.nabble.com/PDF-not-working-correctly-in-deployed-WAR-file-on-Tomcat-tp15295911p20808629.html
>> Sent from the Apache Forrest - Users mailing list archive at  
>> Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/PDF-not-working-correctly-in-deployed-WAR-file-on-Tomcat-tp15295911p20829353.html
Sent from the Apache Forrest - Users mailing list archive at Nabble.com.


Mime
View raw message