forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Can i run Forrest with Java 1.6?
Date Sun, 28 Sep 2008 01:03:51 GMT
Ross Gardler wrote:
> Markus Kramer wrote:
> >
> >i have Java 1.6 and had read, that forrest only runs with java 1.4?
> 
> Where did you read that. I seem to recall that the 0.8 release was fully 
> tested on java 1.5.

It might be a misinterpreation of our README.txt
"A Java 1.4 or later compatible virtual machine
for your operating system."

> >Or can anybody tell me, how i can run forrest under java 1.6?
> 
> I use SVN head, before we recently changed Cocoon versions it ran fine 
> on JDK 1.6. I'm not sure about the current head as it has a bug on 
> Windows which is probably not related to JDK 1.6
> 
> However, Forrest does not *officially* support JDK 1.6 so your mileage 
> may vary (there are some reports of problems in the archives)

Markus, please see the following issue. Is that the
problem that you encounter?

https://issues.apache.org/jira/browse/FOR-984
"validate-sitemap target fails relaxng validation
on some JDK 1.6: missing datatypes"

-David

Mime
View raw message