forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thorsten.scherler....@juntadeandalucia.es>
Subject Re: PDF not working correctly in deployed WAR file on Tomcat
Date Mon, 03 Mar 2008 08:56:19 GMT
On Thu, 2008-02-28 at 02:35 -0800, SteveOdlind wrote:
> Hi all,
> 
> If there is no quick fix to get images in PDFs displayed in deployed WAR
> files, is there a way of getting PDFs to be displayed at all when the webapp
> directory is deployed on Tomcat?

Hmm, my problem with this issue is that I cannot test it (in linux it
works fine). In any way the images in pdf are quite hacky and lately
they have been done some work on the pdf plugin to overcome this
problem.

> 
> I have deployed the webapp directory on Tomcat, and the HTML is displayed
> fine. However, clicking on the PDF icon gives the error message "Resource
> Not Found".
> 
> There are no error messages when I run the command "forrest run-webapp".
> Everything seems to be built correctly.
> 
> If I manually copy the PDFs to the
> "build\webapp\project\src\documentation\content\xdocs\" folder then the PDFs
> are displayed. But surely this can't be the correct way?
> 
> Any ideas?

I expect that the solution is updating the pdf plugin to 0.3 of trunk
but since https://issues.apache.org/jira/browse/FOR-1074 I cannot ask
you test but you may watch this issue and try as soon we fixed it.

salu2


> 
> -Steve
-- 
Thorsten Scherler                                 thorsten.at.apache.org
Open Source Java                      consulting, training and solutions


Mime
View raw message